2

I am trying to import the following EPS file in Inkscape (version 0.91 on Debian sid):

%!PS-Adobe EPSF-3.0
%%BoundingBox: 0.000000 0.000000 850.393701 566.929134
newpath
42.519685039370 73.646254810015 moveto
127.559055118110 73.646254810015 lineto
212.598425196850 73.646254810015 lineto
297.637795275591 73.646254810015 lineto
382.677165354331 73.646254810015 lineto
467.716535433071 73.646254810015 lineto
552.755905511811 73.646254810015 lineto
637.795275590551 73.646254810015 lineto
722.834645669291 73.646254810015 lineto
807.874015748032 73.646254810015 lineto
1.014173 setlinewidth
0.0 0.0 0.0 setrgbcolor
stroke

As you can see, this EPS describes a straight line, although it is broken in many intermediate points. After importing I would like to see handles corresponding to all the intermediate points, but Inkscape automatically simplifies them and just retains the initial and final handles.

Is there anyway to obtain the behavior I would like to have?

EDIT One workaround I have is to randomize a little the points, enough so that Inkscape does not detect the resulting line as straight, but not too much so the difference is not visible. I would like to find a better way.

1

I don't know whether it is possible to turn off path simplification in Inkscape but it seems you generate your EPS file programmatically. If it is true it would be simpler just to generate SVG file instead and directly open it in Inkscape:

<svg height="850.393701" width="566.929134">
  <path d="m 85.03937007873999,0. 85.03937007874,0. 85.03937007874097,0. 85.03937007874003,0. 85.03937007873998,0. 85.03937007873998,0. 85.03937007874003,0. 85.03937007874003,0. 85.03937007874094,0." style="fill:none;stroke:black;stroke-width:10.14169979" />
</svg>
  • encapsulated postscript is easier to generate than svg. As its usually less verbose. But yes for inkscape svg is certainly easier. Its easier to find postscript dump routines. – joojaa Sep 7 '15 at 12:26
  • This can be a workaround, but I would like to know how to solve the general problem. Thanks. – Giovanni Mascellani Sep 8 '15 at 11:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.