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I realize similar questions have been asked here and there, but I'm still a bit confused.


So, the task is basically to make a print-ready EPS/PDF for some vector art prepared in Inkscape [on a Unix-like OS] with some guarantee that the colors are not going to be messed up when printed.


The main problem is that Inkscape is not able to export ICC-profile-aware EPS/PDF files. As is suggested e.g. here and here, Scribus is the way to go.


The workflow is as follows:


	get the ICC-profile your prospective printing centre recommends and link it in Inkscape ("Document Properties" → "Color Management")
	when assigning colors to objects first go to the CMS tab and choose the right profile
	save the file as plain SVG
	import the resulting SVG in Scribus
	choose the right ICC-profile in "Document Setup" → "Color Management"
	go to "Save as PDF" and before clicking "Save" choose "Color" → "... intended for: Printer"



My concerns in this respect are:


	Is the outlined approach valid in terms of bringing the desired outcome? grep -ia icc doesn't yield any hit for the resulting PDFs (tested with Scribus 1.4.2 and 1.5.1)
	What does "Save as EPS" do in Scribus?
	Even being very careful (avoiding gradients, shades etc.) doesn't help to make Scribus (both 1.4.2 and 1.5.1) render big SVG files correctly: some things get messed up. It is also highly preferable to do the SVG to EPS/PDF conversion in a command-line tool. Is there any appropriate one? It seems, Uniconvertor is no alternative, because there is no way to specify the ICC-profile, is this statement correct?



Here is a file to play with. It contains two boxes with colors bound to the ISOcoated v. 2 ECI profile (downloaded here, saved in /usr/share/color/icc/ISOcoated_v2_eci.icc) (the boxes being black in browsers is as expected).


Update


Here are the settings I choose for the test SVG in Scribus (1.5.1).


"Document Setup"  → "Color Management"





"Save as PDF"  → "Color"
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                Regarding your question about needing a command-line SVG->PDF conversion tool, Inkscape can actually be used commandline. Of course, given that your issue is with Inkscape's color management, this probably won't help you. Scribus doesn't have a commandline interface yet.
                
                
– Scribblemacher
                

                Sep 8, 2015 at 14:42
            

        

    
	
        
            
            

        

        
            
                
                I think there's the core issue that Inkscape simply doesn't support CMYK. So no matter what, you will never be able to spec the colors correctly in Inkscape to begin with.
                
                
– DA01
                

                Sep 8, 2015 at 16:49
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                @DA01 What do you mean by "[Inkscape] doesn't support CMYK"? The only issue I see is that it is not able to export PDFs with color profiles, but you can still work in CMYK space, assign profiles and save the stuff in SVG.
                
                
– alephreish
                

                Sep 8, 2015 at 20:54
            

        

    
	
        
            
            

        

        
            
                
                @har-wradim when working with design files for print (offset printing) you use CMYK color definitions. Unless Inkscape recently added it, this is not something Inkscape supports. It only uses the RGB color space. So there's always going to have to be a conversion between the RGB colors to CMYK at some point--which lessons any guarantee of the colors "not going to be messed up".
                
                
– DA01
                

                Sep 8, 2015 at 20:58
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                'doh! Well look at that! THERE IS CMYK support in Inkscape! All these years I thought it was RGB only! Ignore everything I said! :)
                
                
– DA01
                

                Sep 9, 2015 at 22:45
            

        

    


	    


        
                    
                 | 
            Show 4 more comments
        
         
    

    







                
                
                
                    
                    
                        
                            
                                
                                        5 Answers
                                    5
                                

                            

                            
                                


    
        
            Sorted by:
        
        
            Reset to default
        
    

    
        
                        Highest score (default)
                    

                        Date modified (newest first)
                    

                        Date created (oldest first)
                    


    





                            

                        

                    



                                    


    
        
            
        
            
        
        
            6
        

        
            
        


        

    
    








            
                
                    
                

            


    
    




        


        


    
    
Since no ready-to-follow answer has been posted I'll try to answer the question myself.


So, the trick to force scribus to embed (the correct) profile is to choose PDF/X as the output format. When checked with the ZePrA's Extract ICC Profile tool the PDF/X version of the original drawing does contain the profile, while a PDF 1.5 version does not. See the actual updated workflow below:


	get the ICC-profile your prospective printing centre recommends and link it in Inkscape ("Document Properties" → "Color Management")
	when assigning colors to objects first go to the CMS tab and choose the right profile
	save the file as plain SVG
	import the resulting SVG in Scribus
	go to "Save as PDF" and before clicking "Save" choose one of the "PDF/X" options in "File Options" → "Compatibility" and ensure that the correct ICC-profile is selected in "Pre-Press" → "PDF/X Output intent"



There doesn't seem to be any good alternative to Scribus. One thing it doesn't support at all is text boxes in frames. This is easily remedied by making a copy of the svg with all text labels replaced with outlines. To do this massively: select all in Inkscape and select "Path" → "Object to path". Some other minor rendering bugs may still remain.


The "Save as EPS" option in Scribus produces eps files (it seems) in RGB colorspace. Converting PDF/X files with embedded profiles to PostScript with acroread -toPostScript drawing.pdf && ps2eps drawing.ps [using acrobat reader and ps2eps(2)] seems to at least preserve the colorspace.


Better suggestions and improvements are welcome.


UPDATE


I have had some negative experience with ps2eps and would now recommend to convert PDF to EPS directly with the pdftops tool (optionally cropping the PDF beforehand with pdfcrop): pdftops -f 1 -l 1 -eps "drawing.pdf" "drawing.eps"
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Here's an info-graphics I made to explain all the process of preparing a professional print work in Linux.
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                How is this different from the accepted answer besides lacking any details and adding a mysterious step with a Python logo? Is this a self-promotion?
                
                
– alephreish
                

                Sep 13, 2016 at 19:57
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concerning the "save to eps" feature: it is (or at least it was) meant for the older ps/eps based workflows. PDF is the best output from scribus. stick to it except if the printer asks you for something different.
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concerning the importing of the SVG file:


if your svg cannot be correctly imported and you think that you're not using any of the content types that are likely to be unsupported by scribus (the rule being: if it can directly be translated to pdf, scribus can and should support it), please upload it to the bug tracker.

you can mark it as private if you don't want it to be "world readable" (then only the devs can see it).

you should probably also provide PNGs with the desired rendering and the one you get from scribus.


[in the comments to first answer concerning the ICC profile, har-wradim already said that he has prepared an SVG that he can submit to the bug tracker]

    

    
        
            
            
                




    

        
            Share
        



                    
                        Improve this answer
                    


                
                    
                        Follow
                    
                







    

    



            



            
                
    
        
            answered Sep 9, 2015 at 12:53
        

        
    

    
        

    

    
        a.l.ea.l.e
        
            1,07277 silver badges1010 bronze badges
        

    





            

        

        
    
    

    






             
    
        
            

	    


        
                    Add a comment
                 | 
            
        
         
    

    




                                    


    
        
            
        
            
        
        
            1
        

        
            
        


        

    
    








            
                
                    
                

            


    
    




        


        


    
    
The short answers to you two main questions are:


	Are the steps mentioned above correct? Yes, they seem to be correct!
	Why can't I find an ICC profile in the PDF generated by Scribus? Because it should not be there and because the tool you are using does not seem to be able to detect color profiles.



The rest of this answers goes into the details of your second main question.


Generally speaking, the stable version of Scribus does (or pretends to) not fail at correctly processing the ICC profiles. If everything is correctly setup, of course.

No relevant issue is known for the development version, either.


Here some comments about the checks you have done:


	You should use professional preflight tools for checking your PDFs; eventually by asking your print shop to have a look them.
	pdf-parser.py does not seem to be able to detect ICC profiles, even when I make sure that one is embedded in it, by looking at at the raw data with a text editor.
	extractICCprofiles.ps from the Ghostscript project finds ICC profiles embedded by Scribus into PDF files.



Here some more details about the way Scribus uses and embeds ICC profiles:


If you have activated the Color Management and you are using "Printer" as a target in the PDF export (as you are doing), Scribus will convert all the colors to the target color profile. Since the colors are now been converted, the ICC profile is not embedded in the PDF file.


If you check the Use Color Profile option for Solid Colors, the colors are not converted to the target profile and the profile itself is embedded into the PDF, so that it can be considered in the further processing steps.

The same applies for the Use color Profile option in the Images section. 


If you your printer did not specify otherwise, the default behavior, with no ICC profile embedded, is what you are looking for.


If you have the feeling that this behavior is wrong (and can find sources that define how it should be!), please fill a request in the Scribus issues tracker.


Color Management is a hard topic and Scribus' documentation on it is way too sparse. But with a bit of luck, this answer will improve the documentation... 


[edit: i've removed the answers concerning the support of the svg feature and the eps export and filled as separate answers: they are not the main topic of this question]

[edit: after having received more information, edited the answer to be a real answer; the original answer was asking for more details, since i did no have the right to add comments]

    

    
        
            
            
                




    

        
            Share
        



                    
                        Improve this answer
                    


                
                    
                        Follow
                    
                







    

    



            

            

    
        
            edited Sep 11, 2015 at 13:27
        

        
    

    
        
    

    
        
        
            
        

    



            



            
                
    
        
            answered Sep 8, 2015 at 14:11
        

        
    

    
        

    

    
        a.l.ea.l.e
        
            1,07277 silver badges1010 bronze badges
        

    





            

        

        
    
    

    






            8 
    
        
            	
        
            
            

        

        
            
                
                Thanks for the reply. Please see the updated version of the question.
                
                
– alephreish
                

                Sep 8, 2015 at 20:48
            

        

    
	
        
            
            

        

        
            
                
                Yes, if I choose "Solid Colors" → "Use color profile" then it is embedded in the output. But fst, my profile doesn't appear on the list and second, I thought this was about replacing an existing profile, since it is already set in "Document Setup" (see the screenshots). If this last idea is not correct, how can I choose the right profile in that dialogue? Concerning SVG rendering bugs: this seems quiet consistent, I think I can come up with a minimal simple example for the bug tracker.
                
                
– alephreish
                

                Sep 8, 2015 at 20:49
                        
                            
                        
            

        

    
	
        
            
            

        

        
            
                
                - concerning the svg rendering: nice! let's hope it's something the team can fix!
                
                
– a.l.e
                

                Sep 9, 2015 at 12:19
            

        

    
	
        
            
            

        

        
            
                
                @har-wradim:   concering the ICC: i think that you should explain what is the real life problem you're facing. since i've not heard of complaints similar to yours and since the answers i'm getting from more skilled people tend to confirm that scribus is doing the right thing, i wonder if you're sorrows are of only on the theoretical level (this means that you should not provide the print shop with a PDF as you want to have it :-)   but you might have a real issue and there is indeed a problem somewhere...
                
                
– a.l.e
                

                Sep 9, 2015 at 12:28
            

        

    
	
        
            
            

        

        
            
                
                No, the question is about the workflow and not about any specific files. You haven't answered the question: should one explicitly choose "Use color profile" in "Save as PDF" → "Color" → "Solid Colors" or not? If yes, why doesn't the profile actually used in the SVG file appear as an option although it is located in /usr/share/color/icc/?
                
                
– alephreish
                

                Sep 9, 2015 at 22:10
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        Thanks for contributing an answer to Graphic Design Stack Exchange!
	Please be sure to answer the question. Provide details and share your research!

But avoid …
	Asking for help, clarification, or responding to other answers.
	Making statements based on opinion; back them up with references or personal experience.

To learn more, see our tips on writing great answers.
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