I must have accidentally clicked something in Photoshop because all of a sudden my rectangular marquee tool is not working correctly.

When I use the rectangular marquee tool to, for instance, surround something I want to delete on a document, it immediately does one of 2 things:

  1. It turns into a rectangle with rounded edges, or

  2. A box pops up on my screen that says

    WARNING: No pixels are more than 50% selected. The selection edges will not be visible.

    There is an "OK" button in the lower right hand corner of that box. When I click "OK" the box disappears but so does my rectangle on my document.

  • I should add that everything was working find all morning and then all of a sudden this started happening, which is why I am pretty sure I must have accidentally clicked something in the program. Thank you to anybody who can help rescue me LOL – Todd Headlee Sep 27 '15 at 16:23
  • Hi Todd. Can you include a screenshot or two of what's going on? It sounds like you've got some feathering on your rectangular marquee tool (the rounded corners), and it also sounds like you might be using it on a layer that is empty (the "no pixels selected" prompt). But it's hard to know for sure. – Vicki Sep 27 '15 at 16:57

Do you mean the rectangle tool or rectangular marquee which is used for selections? Judging from the way you describe the problem I am assuming the latter. Here are things to look for:

  1. Is the active layer a blank layer or one with blank areas which may explain one way of not getting anything selected
  2. Alternately, is the layer a faint copy of something else which will have low density pixels
  3. Check the feather settings for your marquee, it may be too large (say 500px) thus giving you the rounded corners
  4. If you select a part of a layer with a heavily feathered marquee and make a new layer by copy, the result may have pixels that have low density. If you select something from that new layer now, you MAY get the warning message you are getting. Although the selection edges may not be visible, it will still select "somethings"

The rounded selection and the warning are both a result of feathering your selection.

Feathering essentially blurs your selection. That blurring errodes the corners of your rectangle, so what you see is a rounded rectangle selection:

enter image description here

The "marching ants" that show your selection can't show a partial selection, so only pixels that are more than 50% selected are included and you don't see the feathering. To see this more clearly you can hit the Quick Mask Mode button:

enter image description here

With that in mind, the warning makes a bit more sense. Since only pixels that are more than 50% selected are shown, if your selection is small enough that the "blur" of the feathering reduces the entire selection to below 50%, there is nothing to show.

enter image description here

Although you don't see any marching ants, there is a selection. Enable Quick Mask Mode again and you will see it (although it may be very subtle):

enter image description here

Simple solution: Set your feathering to "0".

check your image resolution ie; file resolution ... you can select when it is in high resolution

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • Hello L Naveen, welcome to GD.SE and thanks for your input. Could you please explain a bit more why this solves the asker's problem? Personally, I rather doubt whether image resolution has any effect on a tool functioning or not. Please back your answer. Thanks! If you have any questions about the site, have a look at the help center or feel free to ping one of us in Graphic Design Chat once your reputation reaches 20. Keep contributing and enjoy the site! – Vincent Sep 29 '15 at 11:20

Set the feather input to "0". That's all. Good luck.

I checked my settings ,every thing was right accept STYLE.There FIXED SIZE was selected,I changed it to NORMAL ,and it worked.

enter image description here

Try to switch between these. That worked for me.

  • 2
    Please add also an explanaition what the marked buttons mean ... Welcome to GD.SE! – Kurt Jun 30 '16 at 3:33
  • Hi ritz, welcome to GDSE and thanks for your answer. If you have any questions, please see the help center or ping one of us in the Graphic Design Chat once your reputation is sufficient (20). Keep contributing and enjoy the site! – Vincent Jun 30 '16 at 8:41

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.