Like a million people out in the real world, I do not understand how strokes work in Inkscape, and do not have the time or dedication allotment to really learn.

I have through sheer act of luck and chaos succeeded in creating a path with a stroke as seen below:

Unequal stroke width distribution along path

This is not what I wanted. I wanted a stroke with equal width throughout, just like the way that is default in many other vector graphics editing programs like Adobe Illustrator or CorelDRAW.

I have thankfully found out how to switch off this functionality in this question. But I sometimes forget to switch it off, and get these kind of unwanted results. How can I reset the width of stroke to an equal value along a path?

  • Can you elaborate how you created this, maybe by looking at your undo history? I have no idea how I would create this effect in Inkscape.
    – Wrzlprmft
    Oct 15, 2015 at 11:45
  • Just make sure the option from the question I linked is enabled. You eventually end up with distorted strokes.
    – osolmaz
    Oct 15, 2015 at 11:56
  • 1
    Let me elaborate: I have been working with Inkscape for years (including with “that option”) and never seen such a thing nor would I know how to create this if I wanted to. I can imagine that there are filters for this, but you can hardly activate them unintentionally. Unless I missed the recent inclusion of a function causing this, it is very likely a bug (which would be off-topic here) or your picture isn’t showing the whole picture, e.g., there are overlaying paths. As it stands, all I can tell you is: This should not happen.
    – Wrzlprmft
    Oct 15, 2015 at 12:03
  • 1
    For the million people you refer to, there's always the manual ;) and tons of tutorials out there in all formats, levels of difficulty and flavors. (Granted, the manual is starting to become a bit outdated, but 90% of it is still very accurate, and more than sufficient to understand how Inkscape works).
    – bartovan
    Oct 15, 2015 at 16:43

2 Answers 2


What probably happened is you had a shape selected when using the Drawing tool. When you select the drawing tool, there is some context-sensitive options at the top, and one of them is shape. What this feature really does is apply a filter to your path (it also may swap fill and stroke).

You can remove it by clicking Path → Remove Path Effect. If the result fills in the blank space in the shape, open Fill and Stroke Ctrl+Shift+F and make sure that fill is set to none and the stroke paint is set correctly.

Bonus Tip:
If you ever see something in Inkscape and you can’t figure out why it’s being rendered that way, select the object and inspect the SVG by opening up the XML editor Ctrl+Shift+X. Often you can diagnose something by looking at its attributes. In this case, you can see that inkscape:path-effect is set, which means a path effect was applied.

Edit: In this case, the issue was a matrix transformation. If you are using the XML editor to try to diagnose why something is happening, use the SVG 1.1 specification to learn more about what different attributes and elements are used for. In addition to the official W3c spec, the MDN also has some great information about SVGs


I solved it using Scribblemacher's bonus tip! You just need to go to the XML editor of that shape (select it and press Ctrl+Shift+X), then select the last item in the Value box (the one begins with "matrix") and set the first 4 numbers to 1,0,0,1 and press Set.


Usually the shape will be scaled and moved, but it would 'equalize' the stroke

  • I've updated my answer to include more information, such as using the SVG spec and other references. If that is what solved your problem, can you mark it as the accepted answer? Jul 22, 2016 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.