3

How do I keep Word document formatting the same as it appears in Word when copy/pasting into InDesign?

I have tried several methods and the text becomes homogenized in InDesign and loses all formatting, including bold and italics. This will be for formatting an ad journal of 300-500 pages.

  • 2
    That's actually in the Help (it's in Preferences) but looking for it, I came across this, which explains it much better: indesignsecrets.com/pasting-formatted-text-into-indesign.php – usr2564301 Oct 20 '15 at 19:33
  • @Jongware This is an awesome trick, you should post your comment as an answer and add the info from the link you suggested! – go-junta Oct 20 '15 at 22:04
  • Try to change the font in word, maybe with common font, like the old one 'times new roman'. I just try it and it works. hope it works to you too – astari Apr 13 '17 at 14:47
4

Another option from the one mentioned in the comment: You can link your Word file the same way as you do for images and even use the same stylesheet as Word if you want. If you work on a big file, it can be useful and even faster than always copy/pasting texts.

Import text into InDesign

When you import your text file, you can select to preserve some styles, images and formatting. You can select "preserve styles and formatting from text and tables."

If you had stylesheets in Words, you might need to merge them with your InDesign ones or replace them. When you'll make updates on the text of your Word file, it should update as well in your InDesign file but it doesn't work the other way around (from InDesign to Word), so be careful! It works in the same way as imported vector or raster work in InDesign.

Even if InDesign allows inline graphics import from the Word file, it doesn't always work well. But the technique is perfect for text-only Word file.

Import Microsoft Word into Adobe Indesign

Here's a link with some details about it preserving stylesheets:

http://www.creativeprogression.com/placing-ms-word/

  • 1
    I missed the OP's "hint" (hum hum) that he's using this for entire files! While mine answers his literal question, this one should be the 'accepted' answer: there is nothing wrong with InDesign's native Place Document option! And it has loads more useful options. – usr2564301 Oct 20 '15 at 22:34
4

This can be changed in the global application "Preferences". Image from CS4/Mac OSX (other OS and versions may differ in detail):

clipboard handling preference

Summarized from David Blatner's InDesignSecrets:

Open the Preferences dialog box (Command/Ctrl-K) and look for the When Pasting Text... option. In CS3, it's in the Clipboard Handling pane of the Preferences dialog box. In CS2 it's in the Type pane of the dialog box. Change this from Text to All Information.

and from Adobe's own Online Help:

Paste text from another application

  1. To preserve formatting and information such as styles and index markers, open the Clipboard Handling section of the Preferences dialog box, and select All Information under Paste. To remove these items and other formatting when pasting, select Text Only.

  2. Cut or copy text in another application or in an InDesign document.

  3. If you like, select text or click in a text frame. Otherwise, the text will be pasted into its own new frame.
  4. Do one of the following:
    • Choose Edit > Paste. If the pasted text doesn’t include all the formatting, you may need to change settings in the Import Options dialog box for RTF documents.
    • Choose Edit > Paste Without Formatting. (Paste Without Formatting is dimmed if you paste text from another application when Text Only is selected in Clipboard Handling Preferences.)

I cannot recall if the default for this option in a fresh install is "Text Only", but if it is just enable "All information" because you always have the explicit option to "Paste without formatting" in the Edit menu.


There is actually no need at all to use copy/paste for entire files. InDesign's native Place Document feature can place most Word files immediately, without having to open them in Word first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.