8

Anyone knows why two different layers (a shape and a text) with the same opacity (54%), fill (100%), blending (normal) and color (#000) render with different brightness?

See following example:

TEST.png

The corresponding PSD file can be download here:

https://www.dropbox.com/s/aqetx9cnxy2ok7p/TEST.psd?dl=0

I have noticed that it is actually the text layer which renders wrong - so when grouping the text layer and setting the opacity of the the group to 54% it renders correctly.

May it just be a bug or do I miss something here?

UPDATE:

I was finally able to file a bug report at photoshop.com - so if you have the same problem feel free to vote it up:

http://feedback.photoshop.com/photoshop_family/topics/text-and-shape-layers-with-same-opacity-fill-blending-and-color-render-with-different-brightness?rfm=1

Let's see what Adobe says...

UPDATE:

As already mentioned in the comments Chris Cox from Adobe replied:

Not a bug - it's because text is blended using a different gamma in order to make the antialiasing look better. You can disable that in the color settings.

So to "fix" this issue:

  • Open "Color Settings" Dialog
  • Uncheck "Blend Text Colors Using Gamma" Checkbox (Sorry, screenshot only available in german)

enter image description here

See comment from @ACEkin for an english translation. English screenshot from @ACEkin below:

english screenshot

closed as off-topic by Hanna, Scott, Vincent Oct 23 '15 at 14:24

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This appears to be a tech support question about fixing technology to work as advertised. Please edit the question so that it pertains to using technology to solve a design problem. You may want to check if it hasn't already been asked in Super User. In many cases, contacting the manufacturer is the quickest option." – Hanna, Scott, Vincent
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    that's strange, i got the same render issue when opening your psd file. It doesn't help to export etc. like @John Manly answered .... – Code 3 Oct 22 '15 at 15:26
  • 1
    @ Johannes, Scott and Vincent - At the point where I asked the question it was not sure whether it was a technical issue or if I might need advise in handling Photoshop to actually improve my design workflow. Nevertheless it is up to you to decide over it - but I think it might be relevant for others here too. – conceptdeluxe Oct 23 '15 at 14:47
  • 2
    BTW - regardless of the on- / off-topic discussion - I don't know how you usually handle on hold questions - but for me and those who helped here it would be nice have this question stay at least for while here until Adobe maybe reacts on the bug report (as it is linked there and this discussions provides significant findings on it) - I think that would be great! – conceptdeluxe Oct 23 '15 at 14:57
  • 2
    Just to bring a closure to the issue, Adobe says this is due to text being rendered at a different gamma to have better anti-aliasing. This setting can be changed under Color settings, here is a screen capture showing the location of the setting: copy.com/nbepJKH0YjqXOmBd – user45605 Oct 25 '15 at 15:41
6

This has me really stumped!

After checking your PSD I decided to run some tests in a new document and I'm getting exactly the same results. Even after closing Photoshop, restarting and starting fresh.. I get the same results again.

I was sure this has never happened before but even opening old PSDs I get the exact same result, so unless your PSD has somehow affected Photoshop then I'm guessing this is a bug.

The problem seems to be with text layers as rasterizing the text layer gives the same color output as the shape layer. I tested with a number of colors and fonts, so the issue isn't color or font specific. Here is a test example with 1. A shape layer and text layer at 100% opacity, 2. A shape layer and text layer at 50% opacity and 3. A shape layer and a rasterized text layer at 50% opacity. All layers are the exact same color and the third example is exactly the same as the second, all i did was rasterize the layer, nothing else:

enter image description here

If this is a bug i'm surprised that I've never noticed and as far as I can find, nobody else has.

Update:

After further testing, it seems the issue only occurs in RGB documents. The issue doesn't occur in CMYK, Lab Colour or Greyscale documents.

I also tested a number of RGB color profiles and all the profiles I tested reproduced the issue, although to varying degrees. The default sRGB profile was the least affected out of the random selection of profiles I tested.

  • Crazy thing - you are absolutely right - I've just tested it again with a new document, after restarting Photoshop and even after rebooting - it is completely reproduceable. Which version do you use on which OS? For me it is Photoshop Version 2015.0.1 20150722.r.168 x64 on Windows 7 x64 – conceptdeluxe Oct 22 '15 at 23:53
  • Well ... it seems like I have a talent for discovering bugs ... I've just tried to submit a bug report via photoshop.com but when I try to register an account I just get "An error occurred creating your account: undefined method `has_latch?' for nil:NilClass" ... :D – conceptdeluxe Oct 23 '15 at 0:03
  • Are you sure you're not causing these bugs! ;) I'm using Photoshop CS6 Version 13.0.6 20131025.r.54 x64 on OS X 10.10.5 – Cai Oct 23 '15 at 0:26
  • @conceptdeluxe Cai Morris didn't find why you got that bug but you got some clues about what to do to bypass this until it's fixed: change your color mode. By the way, same issues here, changing color mode seems to work fine and can't see what's wrong with your file... beside being a vector in Photoshop (heehee! ;) Anyway +1 – go-junta Oct 23 '15 at 7:52
  • 1
    @go-meek Thanks for pointing me in that direction! Based on that I have also checked alternative channel bit depths modes and infact 32bit/channel depth is the only RGB mode where the layers behave the same (though it renders brighter at all). Nevertheless nothing is really practical as 32bit eats a lot of memory and CMYK or Lab Colors are not really handy when I need to work with customers RGB color palettes. Anyways... I'll make this the accepted answer and try to file a bug report again. As soon I have a response from Adobe I'll as well update my question with that info. Thanks @ everybody! – conceptdeluxe Oct 23 '15 at 8:45
4

I have no idea what the issue could be, but it seems like a technical one. I downloaded your PSD and the colors look identical to me, both in the PSD and when exported as a PNG. Although, it does appear that the PNG exports a slightly lighter shade, overall.

PSD

psd

PNG

png

UPDATE
When I originally opened this file, the colors were identical, as I showed above. When I hid one of the layers, the colors then changed to reflect the issue you're having. I'm at a loss, on this one.

You can see what I mean below:

gif

This behavior repeats itself each time I open the PSD.

  • Oh wow, that's really strange - even more what you described in your update - so this likely a bug - thank you for having a look ... I almost thought I'd miss something fundamentally here – conceptdeluxe Oct 22 '15 at 15:30
  • I'll make it the accepted answer if no one comes up with something else until tomorrow – conceptdeluxe Oct 22 '15 at 15:32
  • 1
    For the record, I get different colours in both CS6 and CC2014, regardless of whether the top layer is visible or not. The issue is visible even at 99% opacity, though strangely not (as far as I can tell) if the white background layer is hidden. – Janus Bahs Jacquet Oct 22 '15 at 15:49
  • Thanks for adding a gif recording @JohnManly - I can exactly reproduce it as well with the TEST.psd - I did not notice it before as I have just saved and placed it in the dropbox. Interestingly enough in the PSD where I initially noticed the difference (and from where I copied the layers to TEST.psd) it seems to render wrong even without changing any layer visibility (though the file has several hundred layers all with different visibility state) – conceptdeluxe Oct 22 '15 at 15:56
  • Maybe just start over again from scratch? haha @conceptdeluxe – Manly Oct 22 '15 at 16:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.