I'm trying to draw single shape using shape drawing tool in Illustrator but, when I hold click and slide my mouse, it draws multiple shapes. How can I resolve this issue ?here is the screenshot of the issue.

  • 1
    Do me a favor, select the Elipse Tool and simply click on the artboard, insert two values and hit enter. Does it still draw more than one shape?
    – Alin
    Commented Nov 8, 2015 at 16:37

5 Answers 5


Well, This usually happens when using the Tilde (~) key.

enter image description here

It's a "Continuous Duplicates Based on Mouse Movement" function and combined with Alt/Option, Shift/Command and spacebar you can create new and complex effects.

Are you sure your Tilde key is not pressed or locked somehow? Also, try drawing a circle while holding the Tilde key pressed...

I'm asking cause I don't know of a setting in Illustrator that will do this automatically...

enter image description here

PS: Here's an article where you can read about it.

  • Still happens on macOS in Illustrator CC 2017. If none of the above works, you'll have to reboot. Relaunching Illustrator doesn't cut it. I even upgraded to CC 2018 and it imported the bug for me, so it's some OS level issue. If you've come this far, reboot!
    – chris
    Commented Nov 30, 2017 at 7:09
  • TIL ▲ what an interesting feature, I wonder if/how I'll ever use it.
    – Welz
    Commented Jan 25, 2019 at 0:48
  • @WELZ Well, I never found a use for it so far :))
    – Alin
    Commented Jan 25, 2019 at 16:27
  • Drawing action lines.
    – LeoNas
    Commented Oct 30, 2019 at 14:50


I had the same issue, restarting illustrator wouldn't work. I held SHIFT+ALT+~ and dragged the mouse and it went away. Hope that works for you.

  • 1
    Not tilda, it's tilde merriam-webster.com/dictionary/tilde FTFY
    – Luciano
    Commented Oct 30, 2019 at 10:04
  • Chances are your Tilde key was stuck. By pressing it again, you "unstuck" it. Restarting typically doesn't help because this is an issue with the keyboard itself, not the OS - at least every time I've ever seen it.
    – Scott
    Commented Oct 30, 2019 at 17:01

I tried several things but if you press SHIFT + TILDE KEY you can unlock it and ai will stop repeating the patterns. I tried with SHIFT + ALT + TILDE KEY but it wouldnt work. So if youre stuck I guess just try SHIFT + TILDE KEY. Hope it helps.


I've solved the problem "replacing the preferences" with this solution:

  • Close down Illustrator and press Ctrl+Alt+Shift/Cmd+Option+Shift before opening it again (easy but irreversible);

Thanks to this article and Jacob Bugge post: https://community.adobe.com/t5/illustrator/multiple-shapes-behaviour-in-the-shape-builder-tool/td-p/10840695

Hope does the same to you


If you have Problems with the tilde on the Mac keyboard I found a solution that works for me.

Change the keyboard language to " ENGLISH DVOARK"

and hit: SHIFT+CTRL+^

and than change the keyboard language to your regular.

It works!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.