0

enter image description here**enter image description here**enter image description hereenter image description hereI am trying to make a table like structure but the object i.e. a line segment which will connect both top and bottom pieces is not snapping perfectly.What can i do to resolve this issue ?

2
  • Is it a line ? Or is it expanded? – Alin Nov 10 '15 at 11:33
  • It is a line i did not expand it – gaurav Nov 10 '15 at 11:34
0
  • Click on the line
  • Switch to Direct Selection tool and click on the top anchor-point of the line
  • Drag it over the other lines and it will snap to the other line's end

It should look like this:

enter image description here

UPDATE

From your update id looks like the "line" is not a line. It looks more like you used the rectangle tool to create the line or something like it.

Please try to recreate the line and snap it like I suggested above or better yet, select the line tool and create the line directly from one anchor point to another! This has to work. There's nothing that can stand in it's way!

Line vs Line like Rectangle view:

enter image description here

5
  • It does not work like that i tried that ! – gaurav Nov 10 '15 at 11:41
  • @GauravPrachchhak See my updated answer. – Alin Nov 10 '15 at 11:46
  • Update : See above i did it again with line segment tool but then also the small piece would not stick to its place and snap to anchor point ! – gaurav Nov 10 '15 at 11:51
  • @GauravPrachchhak One last try, uncheck the Align to Pixel Grid and while dragging with the DIRECT SELECTION TOOL (the white one) Keep CTRL Pressed ! – Alin Nov 10 '15 at 11:53
  • @GauravPrachchhak Phew =)) Glad to hear it :) – Alin Nov 10 '15 at 11:58
-1

Check "Align to Pixel Grid" in "transform" menu.

2
  • It is already checked ! – gaurav Nov 10 '15 at 11:38
  • 1
    This setting should be same for both objects. – cndfr Nov 10 '15 at 11:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.