I would like to know how to disable smoothing for layer styles in Photoshop so that edges get jaggy.

For example, I create a text layer and disable smoothing in the toolbar. Now, when I go to Layer Styles and enable Contour, while the text itself remains unsmoothed, the outside of the contour is smoothed. How can I disable that?

3 Answers 3


You can use contour on a lot of layer styles in Photoshop to achieve an aliased (non-smooth) effect. You'll need to edit the contour so it looks something like this:


Contour is available in these layer styles:

  • Bevel & Emboss
  • Inner Shadow
  • Inner Glow
  • Satin
  • Outer Glow
  • Drop Shadow

For more info, please take a look at this answer:

How can I achieve a sharp pixel perfect stroke effect in Photoshop?


I assume you are referring to the inner blends used in layer styles.

The best way may be to set the Bevel & Emboss to use "Chisel hard" under "Technique". Beyond that, there's no method to completely disable the blending or anti-aliasing which occurs with the inner portions of Layer Styles.


Sounds like you need to uncheck "Anti-Alias" in the dialog, but on a quick test here I don't see a problem with effects if Anti-Aliasing for the text is set to "None" in the control bar. I don't see any AA being applied by an effect if AA is also turned off for the effect and it remains inside the letter shapes, but keep in mind that most of these effect apply transparency, which has an anti-aliasing effect by itself.

It's hard to remove all traces of smoothing, but on, say, an Outer Bevel with Contour applied, be sure that your highlight and shadow are set to 100% Opacity and Normal blend mode and that you have Anti-Alias unchecked in the Contour dialog.

Then right-click on the effect in the Layers panel and choose "Create Layer" from the context menu. This will give you the bevel highlights on one layer and the bevel shadows on another. You can then use a Levels or Posterize adjustment layer clipped to each one to remove any remaining intermediate shading pixels at the edges or within the effect.

  • I am trying to use the "Contour" effect at the very bottom of the list. There is no "Anti-alias" checkbox there.
    – tajmahal
    Mar 4, 2012 at 4:13
  • That's interesting. Which version of PS are you using, in which language? There is no layer style called "Contour" in any of the versions I have installed currently (CS4, 5, 5.1). Mar 4, 2012 at 5:51
  • I am using CS3 in German language. Apparently, the layer style I was talking about is actually called "Stroke" in the English version, while the one under "Bevel and Emboss" is called "Contour". In German, both are called "Kontur". Sorry for the confusion.
    – tajmahal
    Mar 5, 2012 at 0:21
  • I figured it must be something like that. The last step of my answer is how you would convert the stroke to a non-anti-aliased version. Mar 5, 2012 at 3:59
  • But there is no way to keep it dynamic, i.e. so that the stroke is automatically adjusted when the layer is changed? If I only wanted to create a static stroke, I could simply Cmd+click the layer's icon in the Layers palette to get a selection based on its borders, create a new layer, select that new layer and choose "Stroke…" from the "Edit" menu.
    – tajmahal
    Mar 5, 2012 at 23:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.