60

How do I set up snap to grid in Inkscape? I have a grid enabled but snapping doesn't seem to be working. This answer pointed me in the right direction but still didn't solve my problem.

I am sharing what I learned about snapping to grids in my answer below.

3

6 Answers 6

63

There are several locations in the settings that affect snapping to a grid.

  1. View Page Grid
  2. Document Properties
  3. Snap Controls Bar
  4. Preferences

We will look at each of these. The images may look different for different operating systems, but the general settings should still be the same.

View Page Grid

This does not directly affect snapping to the grid, but if you can't see the grid at all, then make sure that the menu item View > Page Grid is checked. The shortcut key is #.

Document Properties

To get here, go to File > Document Properties... and click on the Grid tab. You can create a new grid by pressing New if necessary. Make sure that it is enabled and that you are snapping to visible grid lines for now.

enter image description here

The next tab over in Document Properties is Snap. Choose Always Snap in the Snap to Grids section for now. You can always refine this setting later.

enter image description here

Snap Controls Bar

If you don't see this toolbar try going to View > Show/Hide > Snap Controls Bar. It looks something like this, though it may be a vertical bar in your setup.

enter image description here

For starters try making the same settings as shown in the image. Depending on what you want to snap, these settings could very well be why it isn't working for you. Read more about them if you need to.

Preferences

To get here got to Edit > Preferences > Behavior > Snapping. If you need to you can adjust these, but if not then just use the settings shown in the image.

enter image description here


Source

4
  • 14
    i followed this but snapping still does not work in inkscape!
    – guesty
    Commented Dec 15, 2015 at 18:43
  • 7
    You have to press alt-when moving something to snap it! SNAP!
    – Roel
    Commented Apr 13, 2017 at 12:11
  • 2
    I am using smooth nodes and so had to also enable the 11th button on the Snap Controls Bar before snapping started working. Commented Apr 15, 2017 at 20:54
  • For some reason Document Properties just doesn't have Snap tab for me. However, the suggestion about using "Show/Hide" to show the snap control dialog, and then clicking one of the snap icons worked for me.
    – Hi-Angel
    Commented Oct 12, 2022 at 9:48
11

This took me forever to figure out as well. It's hardly intuitive. This bug report is what led me to the answer: https://bugs.launchpad.net/inkscape/+bug/1422296

The key is to make sure you have the right combination of 'snap to...' icons selected on the right side of the UI:

To quote the above URL:

    - "Enable snapping", the topmost button
    - "Snap nodes, paths, and handles", the 7th button
    - "Snap cusp nodes", the 10th button
    - "Snap to grids", and "Snap to guides", which are the lowest two 

I didn't have the 10th button active in my case. Activating that button got the snapping-to-grid working for me.

3
  • Was struggling with this issue today. I think I didn't have the 7th and 10th buttons activated.
    – bzm3r
    Commented Apr 14, 2018 at 2:28
  • I can't find these options in Inkscape 1.2 . Commented Jul 9, 2023 at 13:46
  • There is nothing on the right side of the UI Commented Dec 23, 2023 at 20:56
10

I'm not sure when this changed, but in Inkscape 1.2, there is a magnet icon in the top right hand corner of the screen that says "Toggle snapping on/off (%)". Clicking that button turns on snap to grid. So does typing the "%" character (shift-5).

2
  • 1
    It does toggle snapping on and off, but the snapping happens to all sorts of odd positions, not just to the grid lines. Commented Jul 9, 2023 at 13:50
  • 1
    OMG, thank you, I spent so long looking for this. Nothing in Inkscape help suggests this Commented Dec 23, 2023 at 20:57
4

Quick Answer (TL;DR)

In addition to the excellent answers already given, here are some addons:

  • use snap-to bounding box [FN000]
  • place the mouse pointer closest to the edge you want to use as the snap target [FN001]
  • use snap-to-grid with a very large pixel size to verify snap is working [FN002]

Detailed Answer

Context

  • Inkscape 0.91
  • using the snap-to feature reliably

Problem

  • Scenario: UserCelibra wants to use snap-to in inkscape, but it does not appear to be working reliably.

Solution

Use bounding-box snap mode to make the edges of the containing box act as the snap targets

enter image description here

Place the mouse pointer closest to the edge to serve as the snap target

enter image description here

Use snap-to-grid and set the grid lines to a large pixel size

enter image description here

See also

3

Edit: These instructions are for version of Inkscape prior to version 1.0.

  1. Set up your grid via File → Document Properties → Grid and File → Document Properties → Snap as Suragch suggested. Or go to Inkscape preferences → Snapping and Inkscape preferences → Grid to affect all documents you edit. On my Inkscape, the grid spacing was set to 1px which is not going to be helpful, so increase it to something sensible.
  2. When you want to snap something, hold down the Alt key when dragging the mouse.
7
  • 1
    alt constrains dragging to 90 angles but doesn't seem to force a snap to grid.
    – DA01
    Commented Aug 27, 2016 at 3:30
  • Holding down the Alt key no longer enables snapping.
    – wheeler
    Commented Aug 17, 2022 at 23:13
  • Doesn't seem to work in Inkscape 1.2 . Commented Jul 9, 2023 at 13:50
  • @DavidSpector The instructions I gave here in 2016 are for versions before 1.0. For more recent instructions, see: educba.com/inkscape-snap-to-grid
    – alexg
    Commented Jul 11, 2023 at 8:56
  • If there are more recent instructions, how about editing your answer? Commented Jul 12, 2023 at 15:40
2

For version Inkscape 1.3.2 (091e20e, 2023-11-25, custom),

  1. View > Page Grid
  2. toolbar > click toggle snapping

to make it more sensitive to snap, you can enable only snap the node closest to pointer

1
  • This better be upvoted more so more newbies like me can find! and btw I think adding that 'alt' must be pressed for 100% snapping would help so that simply link to this answer is enough for similar questions in other forums, making answer complete as whole!
    – jupiterbjy
    Commented yesterday

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.