2

I am beginning with sketch.

I don't know what happens in my document, you may have a clue. I have a group of objects (originally an .eps file) in a sketch document.

If I copy and paste it into my working document, it is pasted but "invisible". If I ungroup it, it becomes visible. It I group it agin, it becomes again invisible.

Do you a clue of what I am missing here?

Thanks!


EDIT

I have encountered again the same problem... and this solution didn't work.


Go to View > Show Layer List, remove the "Clip" thing (I don't know what it is) :

enter image description here

1

It's hard to say without seeing your document. Three possibilities immediately come to mind.

Clipping mask

If the objects are pasted at a point in the layers where they are effected by a mask, they'll only appear if they fall within the visible bounds. This is what a mask looks like in the layers list.

Layer group with a mask layer

Everything within the top group will be cropped by the mask layer. If you ungroup the layers, the mask will be disabled.

Artboard bounds

Another type of masking that can bite you if you're not familiar with Sketch is grouped objects that fall out of the artboard's bounds. The artboard becomes a mask, just as if the object were partially over-hanging the bounds.

Object cropped by artboard bounds

If you ungroup an object that lies entirely on the "pasteboard" (or if it was never in a group in the first place), Sketch will move it out of the artboard group so that it is not masked.

Sketch is glitchy

There's always the possibility that copying in an antique format like EPS may just be causing problems. Sketch has definitely taken the just ship it approach to development. They have a pretty focused use case (interface design) and they often break other workflows in the process of innovating.

Homer finds a bug

  • You can try with the files from there – Colas Nov 20 '15 at 18:43
0

Right click on the object 'disappearing". Scroll down to Ignore Underlying Mask. Worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.