1

I finish my design eg." design.psd" and save it as a psd file. After that I save to a pdf file, "design.pdf". enter image description here

I modify the psd contents and again, use save as a psd, overwrite the previous "design.psd". It can successfully save to psd file but as I check the file, the psd file only has the flatterned pdf content, only one layer, even has no other layer, group, images..

How do I just save as a psd file simply...

2

While saving the file I think you unchecked the layer option that's why you got a flattened image.

screenshot save as pdf in Adobe Photoshop

1

Only thing I can see is you checked the "as a copy" and removed the checkmark in the "layers" box when you did your "save as..."

Another thing though...

I see you used the PDFx preset.

From the tests I did, even if you kept your layers while doing a "save as...", the PDFx didn't keep them and flatten all your layers together. A standard PDF (or no preset) would have probably be alright, it usually is. I could be wrong, you seem to be using a different version than mine (I have CC2015).

I'm unfortunately not sure if you can revert back to getting your groups and layers because of this. Next time you save in PDF from Photoshop, maybe try using no PDF preset at all or the standard ones. And well, be careful when overwriting your files without closing your document or changing the file names. It's possible you did an overwrite on your layer file.

If your file is still opened, see if you can go back as far as possible in your history; you might be lucky and still have a version with the groups and layers.

Another way is to maybe try opening this file in Illustrator to save some parts.

How to keep the text in vector in Photoshop without rasterizing it or flattening the layers when exporting to PDF?

  • I tried, I successfully saved a psd.I think it is because I removed the checkmark in the "layers" box when I did my "save as"... Actually I didn't change any setting when I saved psd. I guess it is default setting but I didn't notice that the "layers" was unchecked. – NiFeng_Liu Nov 20 '15 at 7:52
0

I recently had the same problem.

This is how I do: 1. Duplicate an existing .psd file. 2. Open it and copy all the layers needed into it. 3. Save. Rename the file.

Voila.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.