1

I am trying to connect two shapes at their intersecting points so that whatever the size of the image, it will still retain its proportions. Currently I am facing these issues:

  • When I combine these two shapes, corners of the triangle starts sticking out as I scale down to a really small size.
  • When both shapes are perfectly aligned at a certain size, triangle offsets from center to either left or right as I start scaling down.
  • Border retains its thickness when it is scaled down, so 3px border at 400x400 looks good but same 3px on 30x30 looks awful. I am not sure if there is a workaround for this!

As you can tell I am a novice Illustrator user and and any help is much appreciated.

P.S Black circles are just to show the problematic intersections. Not part of the shape :)

enter image description here

Thanks...

  • Use round miters and the sticking out effect goes away. Or make the triangle as a clipping of the hexagon using draw inside. – joojaa Dec 2 '15 at 13:07
  • @joojaa I don't see how 'draw inside' works in this case. Can you please provide a step-by-step example as a complete answer below? – paulmz Dec 2 '15 at 17:45
0

Create this shape in bigger size lets say 1024x1024. greater Size = more control you have If you want to save your file in 30x30 then don't scale it down, just save for web and then define the size.

  • Hi. Thanks for the answer. What I actually want to achieve is to export this graphic in SVG format so if it's scaled down or up based on the content of my website, it will retain its proportions. – yucelm Dec 2 '15 at 11:48
  • I think Grouping all your object will solve your problem. – Rishab Dec 2 '15 at 11:56
  • 1
    the answer for your third point is : Go to Edit > Preferences > General, and make sure the Scale Strokes & Effects is selected. By default this is unchecked in Adobe Illustrator. then scale your object – Rishab Dec 2 '15 at 12:00
  • Although this is already marked as the "correct" answer, I am voting this down. It just isn't the solution to the problem in the OP. We are using vector shapes, so size is irrelevant. – paulmz Dec 2 '15 at 17:35
  • @paulmz I think you are not very experienced with adobe illustrator. read my answer again and try it on your own computer then you know how irrelevant is illustrator with small size and large size – Rishab Dec 2 '15 at 22:48
0

When I combine these two shapes, corners of the triangle starts sticking out as I scale down to a really small size.

Border retains its thickness when it is scaled down, so 3px border at 400x400 looks good but same 3px on 30x30 looks awful. I am not sure if there is a workaround for this!

First, you don't specify how you are "combining" the two shapes (basic options are Group or Merge). I think the answer to both of these questions lies inside a new question: where (and why) are there "borders"? If you set your Stroke to None, it should alleviate both of the issues above.

enter image description here

If you must use a Stroke on either of the shapes, you can retain your perimeter by aligning the stroke to the inside of the shape:

enter image description here

When both shapes are perfectly aligned at a certain size, triangle offsets from center to either left or right as I start scaling down.

I couldn't duplicate this issue, but it sounds like it has something to do with the Reference Point. Just make sure that it is at center for the shapes you are resizing.

enter image description here

You should also specify how you are scaling the shape. The simplest way is to select the Group of shapes and either drag the transformation handles (holding down the Shift key to retain proportions) or type in an absolute value for the width or the height in the options bar (making sure the Constrain Width and Height Proportions chainlink is selected). Either method should scale perfectly.

0

If you expand the object, it will convert all strokes into shapes so they will scale with the rest of the objects. Strokes are common problem areas with scaling especially if moving between illustrator and svg on the web.

Select the objects with a stroke and select Object > Expand... enter image description here

Now all of the strokes are gone and everything will scale correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.