I have a small project where the background needs gradient. I was using Phosothop CS5.1 but decided to upgrade to CS6 because it had the dither feature

After upgrading and I opended the file I saw that now there also were some bandings on the shadows!? What the ....

The bandings wasn't there in CS5.1? How to get rid of it!?

The file is 16 bit

enter image description here

And I have also tried to check the dither feature on the background with gradient?! The bandings is also still on the background

enter image description here

I consider downgrading to CS5 because the result got even worse

download file


  • 1
    I can't reproduce this problem in PS CS6. Dithering works fine. But your screenshot shows a wavy structure, not a linear gradient. So the problem might come from some other layers that are blended over the gradient. Without seeing the file it‘s hard to know what's really going on there. Try to isolate the problem by checking layer by layer...
    – AAGD
    Dec 7, 2015 at 23:37
  • Here is the download link to the file wikisend.com/download/415326/slides.psd :)
    – clarkk
    Dec 8, 2015 at 9:47
  • Possible duplicate of Is it really impossible to have gradient without banding?
    – AAGD
    Dec 8, 2015 at 13:05

1 Answer 1


Photoshop's 16-bit mode does not actually display more colors on screen. It uses 16-bit values internally, but shows a 8-bit preview and also 8-bit color pickers. So it creates the impression that you're trying to blend a color difference of 9 RGB units (28/28/28 to 36/36/36) over a distance of 720px. I'm not sure if PS CS5.1 handles this differently. Three options:

  1. Add noise to the background: Add a layer just above the background layer, fill it with 50% gray, set blending to overlay. Now use Filter > Noise > Add Noiseand add some monochrome gaussian noise (~3%). This should be ok even when saving back to 8-bit mode.
  2. As the gradient here is so minimal, you could leave it off and keep the background as a solid color. On most displays you'll not be able to see a difference anyway.
  3. Increase the difference of the colors you want to blend until it looks smooth enough.

Interesting article about the topic: http://nomorebanding.com/cache

Update 2015-12-09:

Working directly in 8-Bit Mode would probably be the best advice here. The dithering of the layer's Blending Options > Gradient will actually look much better instantaneously and without any additional efforts.

  • 1
    While this is a 16-bit file and I am not sure your "6 units comment" is valid for the color range available (i.e. 16-bit color is/can be floating point [an approximation of a real number]), it is quite probable that the layer blend tool itself is 8-bit and then upsampled, and your answer is most likely correct.
    – Yorik
    Dec 8, 2015 at 15:46
  • You're totally right. Actually there are about 733 steps in the file. They are actually all there (Eyedropper in 16-bit mode shows all the values) but PS seems to show only an 8-bit representation. So you don't see what you actually have > WYSINWYH. I never noticed that all tools keep using 8-bit color values in 16-bit mode, except Eyedropper. This article analyzes much of PS's weird behaviour. nomorebanding.com/cache . In the article they came up with a very similar solution using noise. I'll edit out the wrongs in my answer.
    – AAGD
    Dec 8, 2015 at 17:09
  • Actually most monitors can not show more then 8 bit color cheap one not even that. So unless you have a really expensive monitor then you wnt be seeing more than 8 bits. Witha really good monitor gfx card combo you can see 10 or 12 bits
    – joojaa
    Dec 8, 2015 at 17:40
  • Way off topic, but I do sort of wish "they" would pause from upping pixel count for TV and movie use. The most visible problem is banding and wipes that would benefit greatly from higher color precision and these cannot be fixed by throwing more px at it.
    – Yorik
    Dec 8, 2015 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.