6

When I export my newsletter from InDesign to PDF, the resulting PDF, including all transparent graphics, rasters and effects look great on screen.

When I print the PDF to a plotter (Canon IPF8300), there are no issues and the printed results looks great. However when I print to my office printer (Canon ImageRunner c5045), every graphic raster that has an effect (shadow) or is transparent, does not render correctly and I clearly see bounding boxes around these objects.

The entire document and all source graphics are CMYK. This happens whether i run the flatterer or not.

The problem is that the print shop we are using to produce the final product also sees these anomalies. I have no clue as to why the PDF looks fine when printed on a printer A but not on a printer B and C. The only workaround is to export to image and completely rasterize the entire design.

Any ideas?

enter image description here

enter image description here

  • 1
    Go into the printer driver's property pages and see if you can disable any and all vivid, photo enhance, icc profile. Almost all office printers alter your imagery, and the defining factor of your snapshot (other than transparency) is that the vector box colors are probably ignored by the What the Client Must Have Really Wanted Image Enhancer. – Yorik Dec 18 '15 at 22:19
  • There was a slight improvement turning off vivid and other effects. Mainly effect over other raster render correctly. however, effect over vector objects still exhibit the anomalies. I think my workaround will be to ensure all vector objects in the background have a raster (tiff) fill. – Jakub Sisak GeoGraphics Dec 21 '15 at 14:49
2

Thanks everyone for you input. Seems that the printer I am using is not capable of correctly rendering effects and transparencies whether they are flattened or not. I've turned every effect on the driver off and the only improvement was that it was able to render effects and transparencies correctly only if the object was positioned over no colour (paper) or over another raster (image, tiff).

Unfortunately, the same anomalies I am getting on this printer is the anomalies we see at the print shop we are using to have the final product produced. (we have to use this particular shop). This is partially why I was using this above mentioned printer to QAQC the press PDF.

Since I was not able to eliminate the problem I decided to look an older Indesign file that was done by an external design company in hope of some idea. I noticed that they used tiff files for both solid and textured backgrounds. Once i switched to this technique, the files print correctly and there is no significant file size increase.

In short, the workaround that works for me is not to use vector fill below any objects that are transparent of have an effect (i.e. shadow). This is easily accomplished by placing tiff images if that particular CMYK colour in the frames.

  • The good old way of doing things! Simply don't use any drop shadows, transparency with blending mode and such. Usually a tif with different level of opacity works fine. (PS: You can mark your own answer as "accepted" by clicking the little diamond shape next to it.) – go-junta Dec 21 '15 at 16:38
1

There isn't much more to do than rasterizing your layout, and it doesn't change much the quality when printing on a small office or home printer, or even on a digital commercial printer.

Your non-postscript office printer rasterizes the layout in its own way and that's the result it renders based on your effects. I'm just guessing since you're not giving details on that printer.

The plotter has a postscript driver or a RIP, and converts your effects properly.

http://www.justskins.com/forums/printing-transparency-issues-81639.html

  • Sorry, meant to add the office printer name. It's the canon ImageRunner c5045. It's a fairly upscale unit, almost 3 times the price of the plotter... Sounds like the issue is with the printer / driver settings. What puzzles me is that the professional print shop is running into the same problems even though i see no problems with the pdf and can print it without issues on the plotter. – Jakub Sisak GeoGraphics Dec 19 '15 at 15:08
  • @Jakub Thanks, weird indeed. But I see the Adobe Postscript 3 is an optional feature but is supported on your printer. Maybe that's something to investigate or ask Canon customer support just to eliminate that as the cause of your issue :/ Regarding the print shop, do you mean on a digital printer or on offset printing? Unlikely they don't have their stuff updated, but old rips don't read transparencies well, it can always be a possibility. – go-junta Dec 19 '15 at 18:46
  • 1
    Pretty sure they use outdated equipment at that shop. The guy mentioned he's converting the PDFs to RIP which may be the problem. I will try to provide them with a flattened PDF. @Yorik suggested turning off vivid enhancement. there is a chance that vivid is in fact turned on. – Jakub Sisak GeoGraphics Dec 20 '15 at 0:17
0

I don't know if this will work for you, but I am just giving my personal experience!

I had this issue arise 2 months ago, for the first time, on a Xerox Workcentre using an Indesign template that I use every month. It was on any image that had transparency or drop shadows. The only thing that worked was to:

  1. Change placed file types: had to convert and re-link all of my TIFF, AI, and EPS files to PNGs
  2. Turn off the post-script for images on the "advanced" printer settings. I would give more details on how to do this, but I'm not familiar with your printer. The wording was "Post-Script Pass Through: Disabled"

After these changes with this file in particular, everything printed as it appeared on the screen! However, using the same template the following month, the print job worked with all of the aforementioned types of files and I had to turn the post-script back on.

This is a trial and error issue for me, so perhaps one of those changes will help next time you come across this issue!

-1

Printing CMYK over CMYK is extremely difficult, and when transparencies are involved even more so, and to make things another step worse, make excessive use of spot colors.

In Acrobat Pro, in the Print Production Tools, you have the Transparency flattener. This should take care of the transparencies.

In order to get the best quality, do not use JPEG compression, but switch manually to ZIP (you will see what is meant when you have the dialog in front of you).

  • 1
    The anomalies shown on my example occured after I've used flattener. That was the first thing i tried. As i mentioned, it only happens on the the office printer, not the plotter. If I design the whole thing only using RGB, would that help with the effects and transparency issue? – Jakub Sisak GeoGraphics Dec 20 '15 at 0:25
  • I think so; they say that a fully cross-media workflow is RGB based, and that the conversion to CMYK happens either in the RIP, or in the very last step before going to the RIP. – Max Wyss Dec 20 '15 at 14:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.