4

After merging my layers, it seems that the adjustment layers do not apply. The same happens when I export on jpeg also. Is there a reason?

To make you understand the whole process: I scanned some documents and came up with pdf files that contained the scanned information. I exported them to jpeg and later imported them in Photoshop to edit them. I selected all the white parts, using Color Range, then selected inverse and Cmd+J the selection (which was everything but the white pixels). I put a white background layer on the back and the drawing looks exactly like the original, only difference was that I now had one layer with the pencil and one layer with the background, which will suit my later use better. I applied adjustment layers and now they do not apply after exporting, merging or flattening.

Anyone has an answer for this?

Thank you for your time.

Here are some screenshots to see my .psd file also

the three stages that the problem exists

2
  • Looking at your original PSD file will be necessary to better answer your question. Can you make a small version and save it in the cloud to share?
    – user45605
    Dec 23, 2015 at 3:07
  • Old post but..... ALWAYS view at 100% when applying adjustment layers or merging them. Viewing an image at any other scale causes the preview for screen to be anti-aliased.. resulting in a different appearance. This is especially true on one-color/black&white images.
    – Scott
    Nov 26 at 5:03

6 Answers 6

3

It's most likely because the adjustment layers are accounting for "white" background layer in their calculations. If you want to make sure "what you see is what you get" be sure to clip those adjustment layers (OPT click between layers / ALT for windows)so they only affect the layer with the drawing and nothing else. Hope this helps.

2
  • Thanks for your reply ErickP. However, I still get the same result ... Even when I stamp visible (opt+cmd+shift+E) I get the unwanted result (the one with no adjustment layers active). Would you have any other idea?
    – Yorgos
    Dec 23, 2015 at 21:20
  • @Yorgos - Assuming your image is just black, then many of the adjustments don't have much of an effect. They only adjust black levels basically. You'd probably see more of change if the image were in color. The only thing I can think of is to play around with duplicating that layer and adjusting the opacity and/or create layer masks to affect certain area's that you want to affect more than others, until you get the contrast you need. Adjustment layers might not be the way to go for this particular case.
    – ErickP
    Dec 23, 2015 at 21:47
1

I did a quick test using your screenshot, quickly extracting the drawing and adding adjustment layers as you did, flattened it and saved it as a jpg. Then, I closed it and opened it again. The adjustment layers work for me so this may well be a technical issue.

Before: before

After (as a new image): after

1
  • Thanks for your reply KJP. Would you have any other suggestions? Because, this still does not work.
    – Yorgos
    Dec 23, 2015 at 21:20
0

Try using auto resolution. I have this issue occasionally when working with Bitmaps and I believe it is to do with the bit ratio.

Image Size: Fit To Auto Resolution Quality Best

(This lowered the res to 266 which I corrected later) I was able to use adjustment layers and have them take effect.

1
  • The Image Size...Auto resolution was the only thing that worked. Must be a pixel issue or something related when using AdobeRGB to SRGB
    – mark
    Nov 25 at 7:48
0

I had the same problem. Try to right-click on adjustment layer and choose merge down (I don’t know how it will be in English version of Photoshop). For me it works.

0

I had the same trouble. Very frustrating! My solution... Select all layers including the background then "merge layers" worked for me!

No loss of contrast or change in the image. No idea why flatten image should change your adjustments! Especially with contrast I found and sometimes in saturation layers.

I hope this helps someone stuck.

0

Stumbled on this thread today since I am having the same issue. I am also working from a scan which seems to be the problem. When I tried to duplicate my issue using a screen shot instead of the original scan, the adjustment layers stayed when merging/exporting for web. But for some reason, even a JPEG that Photoshop converted from scanned PDF was still acting weird.

My workaround was to:

  • open original scanned image (PDF) in Illustrator
  • save for web as JPEG from Illustrator
  • open new JPEG in Photoshop, now it works fine.

Maybe this will help another lost soul because man was this frustrating!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.