I am creating icons with Adobe Illustrator during which process I use the Align tool quite frequently. All of a sudden, the align tool started behaving quite strangely.

When I select two objects and specify that I want to align to a key object, when I press align it seems to only align halfway to where it should be. When I press align again it aligns halfway again - after I press it several more times, it finally gets to where it needs to be.

Also, when I try to align to artboard, it pushes the object out to a seemingly random place.

Here is a video showing exactly what I mean: http://screencast.com/t/m9xKONroYyEG

What setting did I accidentally set to make align behave like this?

  • 1
    what version of Illustrator you are using?
    – hsawires
    Commented Dec 25, 2015 at 13:20
  • @hsawires Illustrator CC v2015.1.1
    – William
    Commented Dec 25, 2015 at 13:22
  • 1
    Why you don't use Align by top?
    – mrserge
    Commented Dec 25, 2015 at 19:34
  • Well that might work for this one scenario but I definitely need to align by middle for other stuff - what setting could be causing this??
    – William
    Commented Dec 25, 2015 at 19:35
  • 3
    Gotta say, I'm curious. Very odd. Did you trying quitting out of AI and restarting your computer? Sometime I get strange behaviors in Photoshop or InDesign and just rebooting my computer seems to clear out funky cache. BTW... i'm sure you are aware but you can simply just select both objects and simply click on one or the other, which will make it the key object without visiting the top menu. Just thought I'd mention it but I'm sure you were just doing that for the video.
    – ErickP
    Commented Dec 25, 2015 at 19:42

9 Answers 9


This is a glitch.

Saving before using align, then opening the file, does seem to fix it.

My hunch is it has something to do with a partially deleted object and a clipping mask because if one of those elements are missing then this doesn't happen.

enter image description here


When it happened to me, it turns out I had a Guide as part of the group. When I showed the guides, I saw it and unlocked it, deleted it, and tada, everything resolved.


Initially I thought it was very likely you have a element far off that you haven't noticed that you're selecting when trying to align the pieces. But, I agree, this is likely a cache issue. Seems restarting the program or perhaps the computer would help. But if it kept happening, that would be of concern. Maybe if it was only happening with that file, then it was a corrupt file? Too many artboards?

however you may have hit on the answer in your question, look at the settings for the align features, perhaps there is something there? Please post when you have it figured out! That's a lot of extra clicks.

  • Where are the settings for the align feature? I don't see anything that looks right when I go to the settings (Ctrl K)...
    – William
    Commented Dec 26, 2015 at 18:32
  • William, the only thing I'm aware of is the options you should have found where you referenced. I remember, sometimes if it would do this, it was doing it because it was averaging the distance between all of the objects, but once they were aligned once the average was smaller and the second or third time it was hit it came more 'in line' with what I wanted. I'll see if I can do a screencast or something to show you. I've never done one before. Is it possible you have more objects selected than you realize?
    – muwbl
    Commented Dec 26, 2015 at 22:45

So I tried using the align tool with some other objects and it worked as expected. I then ungrouped the erroneous objects and regrouped them. This seems to have solved the problem. I'm not really sure what was causing it, but it seems to be working now!

  • still interesting to find out what was causing the error in first place.
    – Luciano
    Commented Feb 24, 2016 at 13:15

Maybe it had something to do with not aligning the center of the object, but any of the left or right handles. I mean in the status bar you can choose what part of an object you want to align.


Switch the view to outline mode to make sure there isn’t an object or stray element with no fill or stroke (making it “invisible”) grouped with the object you’re aligning. Also check to ensure there is no clipping mask applied to the object you’re alignining, as it will align with the outermost edges of any element used in a clipping mask.


It is typically an application file error. I do not know what causes it or how to remove it in a file once it's seen.

Copy and paste to a New Document.

That will generally clear the "glitch", whatever it is.


Had this same problem when center aligning text with an icon. For some reason if I go in and use unite (in pathfinder) on the icon and then align the icon and text it is fine again.... not sure why but you can try.


If it helps anyone, I just had this with trying to align an SVG icon I'd got from a client. Turns out the icon was grouped quite oddly (rather than being flattened into a compound path) – ungrouping it all about a million times and making it a compound path sorted the issue!

  • It is not odd. Its fairly typical for anything that has been a pdf at some point. So entirely normal.
    – joojaa
    Commented Apr 13, 2022 at 6:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.