I'm working on a large illustration project in Illustrator CC. I hand-drew hundreds of shapes which overlapped to create the image how I wanted it to look. However, I have several shapes that needed to be cut out of ALL the shapes beneath it so that when I save as a PNG the cut-outs will be transparent. (These images will be placed on colored backgrounds in a digital setting). I used the pathfinder tool (Tried Trim and Divide, then used combine to build shapes that were all the same color) and now it seems that there are white lines as some screen artifacting or something? They are definitely not strokes, and when you zoom in and out their appearance changes. The first image shows what I'm seeing in Illustrator, but the problem seems to get worse when I save as PDF.

I've come across this problem before, but it's always been print work. Since this is going to be used in digital, I need to find a fix for this so I can guarantee the image shows correctly. I found I can add strokes of the same color and they will disappear, but that is going to be extremely time-consuming for a project of this size. Does anyone have a fix for this or know a better way for me to create those cut-out transparencies so that I can avoid the problem all-together?

enter image description here

enter image description here

  • It is a rendering artefact caused by coverage sampling. Supersample and it goes away.
    – joojaa
    Dec 31, 2015 at 23:03
  • A clipping mask would solve this problem, but only if you have a version before the pathfinder operation.
    – MG_
    Jan 1, 2016 at 3:55

4 Answers 4


Another solution that is similar to adding a small stroke is to use Offset Path.

Select all objects and then select Object->Path->Offset Path. Set the Offset value to the same amount as you would stroke, this obviously depends on your situation so just use whatever works for you.

This way you don't have to worry about the different colors, you just offset everything at the same time.

Note: Offset Path actually duplicates all the objects, so you end up with all the original shapes and the offset shapes above them. All the resulting offset objects are automatically selected after running Offset Path, so if you want you can quickly hit CMD+X to cut the selected offset objects, delete everything that remains, then CMD+SHIFT+V to paste the offset shapes back in place.

  • This is the best solution, quick and easy. This works beautifully even if you want to use the svg directly in a web application without any conversion to a raster format. Note that offset path accepts offset values smaller than one px, if the viewbox is rather large values of .1px or .01px might yield the best results.
    – glaux
    Nov 15, 2018 at 12:37

If your image is a screenshot from the Illustrator workspace, chances are very good that this is simply a preview artifact, and not something that will show in your exported files. But there are a couple of caveats to this, based on your statement that "it gets worse when you save to PDF". But first, let's take care of your preview problem:

Preview problem

First, I created a quick illustration with grey layers and subtracted the shapes with the Pathfinder, similar to yours, and put a bright magenta background behind it. In Pixel Preview mode, this is what I see (at 300% to minimize the imgur lossiness effect):

enter image description here

So, clearly a reproduction of the sort of problem you're having.

However, without any modification, when I Save for Web as PDF, here's what the output looks like (again, 300%):

enter image description here

Perfect anti-aliasing between the shapes, with no magenta.

Better preview

While Pixel Preview is great for fine-tuning before export, even for screen/pixel design, I tend to do most of my work in GPU Preview mode, so I'm not needlessly distracted by jagged edges and bleed effects. I only switch to Pixel Preview when I need to do detailed alignment or similar tasks. For a real pixel preview, I always check the exported file in Photoshop for anything even remotely important. The only catch is, you need a compatible graphics card for GPU preview mode to work.

Thus, the bleed-through effect you're seeing in Illustrator should go away in your saved files, and can be "turned off" within Illustrator in GPU preview mode.

What if it doesn't go away?

You need to revisit your illustration and look at how you subtracted your shapes. If you resized, shifted, filtered, or otherwise did anything that might alter the outline of your shapes, that could create a persistent version of the problem. You can quickly check this by going into Outline Mode, zooming in to 8000% or so, and verifying that your shape boundaries line up. They should appear as one line at any zoom setting.

Your PDF problem (why raster?)

You've said that the problem is "worse" in your PDF. However you've also said that you're saving these files as PNGs, with other images behind them. Without knowing more about that exact process, I have concerns:

  1. Adobe PDFs support vector art. In fact, that's one of the format's strengths. Why are you exporting to PNG (a raster format) before bringing that in to your PDF design? It's quite possible that the bleed-through you're seeing there is a result of any number of raster alpha channel/zoom/display effects. While the other answers might help you mask the problem ...

    is there a reason you can't keep your illustration in vector format?

  2. Even if your design is going to overlay something that must be rasterized (like a photograph), there's no reason I can think of why you can't keep your scribbles in a vector format. If you still see artifacts, then that would be another question, but I've done many similar designs that have displayed perfectly at any zoom level in about a dozen different PDF viewers that I test with.

Digital problem in general (if PDF isn't your actual destination format)

If the information I've given you here doesn't help, then please let me know more about your actual destination format and your export/merge process with the other images that you alluded to.

In general, you should never have to grow outlines assuming a simple Pathfinder slice job with Illustrator (in fact, that can create other problems), and no shape-altering modifications after that. The only time I've had problems is with quick jobs where I had to go through lossy formats, multiple exports, and that sort of thing. Keep your workflow as simple as you can, and make sure you understand where and how your vectors are being rasterized—that step tends to define the success or failure of such effects.


From what I understand this appears to be the art board that has been revealed after cutting shapes out with pathfinder. Unfortunately there is no quick fix to this. You mentioned adding a stroke of the same color to the objects which would work, but yes it would be time-consuming.

I'd go the route of utilizing foreground, mid-ground, and background.

Meaning: Shapes on top retain their form but overlap shapes below them (in layers panel) See below:

enter image description here

Going back to the original solution; adding a same color stroke to each shape. A quicker way to this would be to:

Select a single shape with a single fill color. Then at the top of your screen click SELECT>SAME>FILL COLOR then add the appropriate color stroke (this will add it to all shapes with that same fill color) repeat for each of your colors (which appear to all be shades of gray)

That should help speed up the process.

  • Yes, you are right about the artboard being the piece that is showing through. If I add a different color behind everything, then that becomes the color of the "Lines". I would have just left the illustration as overlapping shapes if I didn't need the transparent cut-outs, but I've been duplicating/transforming rectangles to make hundreds of windows and so it would also be very time consuming to have to edit overlapping shapes. That's why the divide tool came in handy, being able to cut everything in one click, and then being able to easily delete the shapes that needed to be transparent.
    – Micaela
    Dec 31, 2015 at 19:28
  • I edited my original answer to potentially speed up your process of adding strokes to each shape. I hope that will help :)
    – Grayson
    Dec 31, 2015 at 19:41
  • Yes that does seem to be a reasonably quick solution. I may have to just do it that way unless some other illustrator guru can come up with some obscure answer. Thanks for the help!
    – Micaela
    Dec 31, 2015 at 20:05

So I had this same issue, and the only way I could resolve it was to make crystal clear that the stroke was 1 and that the stroke and the fill were exactly the same with regards to CMYK values. I had to select all the pieces that were supposed to be same color went into the color picker and put in the cmyk values manually because they were slightly off even though the hash tags were the same, the cmyk was not...enter image description here


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.