0

I am currently having a bit of a delima importing excel spreadsheets into InDesign.

The spreadsheets in question use formulas to pull data from other spreadsheets on the network (using vlookup) - currently set as, Part Number (Alpha-numeric, Description (Paragraph), case qty. (number), Price (currency).

When importing the spreadsheet (using File > Import), it imports everything correctly, including the headers; except for the description paragraphs.

I am currently using ID5.5 and the spreadsheets are .xlsx

Is it a bug with InDesign? Am I doing something wrong?

closed as off-topic by Hanna, Wrzlprmft, joojaa, benteh, Zach Saucier Jan 22 '16 at 14:24

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This appears to be a tech support question about fixing technology to work as advertised. Please edit the question so that it pertains to using technology to solve a design problem. You may want to check if it hasn't already been asked in Super User. In many cases, contacting the manufacturer is the quickest option." – Hanna, Wrzlprmft, joojaa, benteh, Zach Saucier
If this question can be reworded to fit the rules in the help center, please edit the question.

1

After doing several tests, I had a hunch that ID5.5 might not be compatible with new excel files (with the .xlsx extension). So I saved my excel spreadsheets with the earlier 2007-2013 version (.xls), and long and behold, it imported the data as desired. I hope that this little tip might help someone who might be having a similar issue. TIP OF THE DAY: Always check for software/document compatibility.

  • This problem still persists, even in CC 2018, and I ran into an issue with .xls files, they are A LOT bigger than .xlxs (mine was like 22 mb instead of 2 mb) and was REALY slow importing. While .xlxs was really fast (and i had many sheets). I mean, .xlxs is now standard for Excel so ideally Adobe should make this work! – Carl Papworth Mar 13 '18 at 12:25
0

Try this

Select "Place" from the File menu. Select "Import Options" and double-click the Excel file containing your spreadsheet. The Import Options dialog box opens. Click the "Sheet" menu and select the worksheet from the Excel workbook that you want to import

  • The issue is not how to import it, but rather that I'm importing a spreadsheet with formulas in them. If the formula results in a number, the number is imported, but if it text, the cell will be blank. This is where I have the problem. – elrayyes Jan 8 '16 at 19:53
  • Right, but importing a document is essentially like embedding it. Placing the file makes it a linked object which can be subject any live modifications. The threads I read through used 'place' instead of 'import'. Sorry I couldn't be more help. Good luck. – mark mathis iv ddrt Jan 8 '16 at 20:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.