2

The standard hotkey convention in Windows is that ALT+TAB switches between programs and CTRL+TAB switches between documents within a program.

Photoshop for some reason wants to treat every document it has open as a separate process, which means if I open Photoshop while developing a website, then open a number of different documents, my task switching gets all screwed up because Photoshop has elevated every document to the level of importance of a separate program.

Photoshop Taskbar Grouping

Is there any way to disable this? I know you can disable taskbar grouping across the board, but this doesn't solve the problem. Instead it gives me four separate Photoshop items in the taskbar, which is even worse.

Ungrouped Photoshop Tasks

How can I get Photoshop to be a little more humble and just occupy one task slot, like a normal, well-behaved program?

  • 1
    I don't have Windows in front of me right now and I can't remember if that is normal behavior or not, but could it be that you have each document in a separate window instead of in tabs? What if you do Window > Arrange > Consolidate all to tabs. – Joonas Jan 14 '16 at 8:10
  • 1
    Surely this is more of a Windows question, rather than a graphic design question? Try right-clicking the task bar and click Properties then change the setting for Taskbar buttons:. – Paul Jan 14 '16 at 9:03
  • @Paul see the second part of my question: "Instead it gives me four separate Photoshop items in the taskbar, which is even worse." - I'd agree it's a Windows question if it wasn't specific to Photoshop. – Nathan Ridley Jan 14 '16 at 13:29
2

Photoshop usually does that when your documents are not Consolidated to tabs. if they are not tabbed, well Photoshop will treat them as different windows(For specific reasons, sometimes you need to see different thumbnails of Photoshop documents in your task bar preview).

Usually a quick trick is going to the Window >> Arrange >> Consolidate All to Tabs (Any of the options listed within the Arrange sub menu will do the trick)

All you have to know is that if your document windows, are not arranged in tabs, they get to be represented separately in the task-bar preview

  • 1
    That's super annoying. I don't like having my documents in tabs :( – Nathan Ridley Jan 14 '16 at 13:26
  • :( @NathanRidley, I understand your pain, though sometimes it is super handy too. For example, I find it quite priceless when working multiple mock-ups that are somehow related to each other(say 16 screens showing the mobile version of the site) and way too different from the rest (say 1 desktop version of the same site), in parallel. Grouping the mobile pages, tabbed together in one window and the desktop in the other makes it easier to switch between the groups from the task bar rather than look through the several open files. – iamcastelli Jan 14 '16 at 19:24
  • :( thanks Photoshop for completely ignoring OS standards – Dirk Boer Feb 23 '17 at 0:10
  • @NathanRidley me too, but I just realised that you can have all documents in tabs in PS, but then 'drag out' the one you're working from at that time. This means the other 10 psds or whatever will stay grouped with photoshop, and just my active psd can be ALT+Tab'd. Not quite what you're after, but it's the best available I think. – crdunst Feb 12 at 18:32
0

You could always just disable preview thumbs on the taskbar completely...

This can be accomplished by editing the registry:

  • Press Windows+R, then type 'regedit' and hit Enter to open the Registry Editor

  • Navigate to this registry key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

  • Right-click on the Advanced "folder" (key), create a new 32-bit DWORD value and call it ExtendedUIHoverTime (yes even if you're on 64-bit).

  • Set Base to Decimal and enter 15000 (or whatever you like) for the Value data.

Registry Editor

This means Windows will only show the thumnail preview after you've hovered over the Photoshop taskbar button for a full 15000 milliseconds (15 seconds).

This way you'll probably never see taskbar thumbnail previews again (unless you really want to).

  • Restart Windows Explorer or log out/log back in to see the changes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.