1

I'm on a Mac, working on an InDesign file. I get some XSLX files with numbers in them, and when I place them into my document, all spaces are replaced with an 'Ê'. I'm thinking this is some issue with character sets, but I'm unable to fix it.

There seems to be no option to save an XSLX file to another character set from Excel. I tried to import my file to Google Sheets, and export it again (this should set the character set to UTF-8), but then InDesign wont allow me to place it in my document at all.

Any ideas?

  • 1
    I would call this more properly an encoding problem (rather than a character set problem). I think you may need to ensure that the encoding the CSV or XML file is using is utf-16. Or possibly, when importing, try specifying utf-16 I think Windows will handle Unicode as UTF-16, but *nixes consider this UTF-8. Encoding is a hairy mess. – Yorik Sep 27 '16 at 17:25
1

You can simply copy and paste xls tables into indesign, as long as you create a table large enough. Although when there are merged cells in the xls the pasted formatting may jump rows. Just be careful and double check everything.

  • This might work but the whole point is to use linked files. I think it makes sense that the source of truth is the Excel-files and not in the InDesign-document. Numbers need to be able to be changed by some other party not responsible for the design. – Johan Dahl Jan 24 '18 at 11:44
1

It's a known bug caused by the separator. You can disable the separator (or change it) in Excel, but if you want to keep your spaces, best acceptable solution is a Grep find/change query : (?<=\d)Ê(?=\d{3})

0

Try exporting excel sheet as a tab delimited text file and make a new table, typefaces etc.

0

I could not get Excel files with thousand separators to show correctly in InDesign. As I said in my question the separator get's replaced by an "Ê". I could of course do a search and replace for this symbol but that is not a good solution since I will have to repeat this each time I change any linked excel-file.

My solution was to remove the separator in the Excel-file and add a GREP-style in InDesign that uses a bigger tracking unit on every third digit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.