0

This is probably a simple problem, but I have an small textbox like this:

Image example

The exact text I have is:

asdfjkasdfasdf asdfadsfasdfasdfasdfasdfa

Illustrator is inserting a line break instead of keeping the space, this is great but in my case I want:

Desired example

I've looked for a while but I can't find a simple setting for this. If this isn't clear, I'll be happy to clarify.

  • How did you get Illustrator to split the first line D and F? – Ryan Jan 25 '16 at 21:41
  • @Ryan on the first line there is no space it's just one long word and illustrator had to cut it off. – Downgoat Jan 25 '16 at 21:46
  • Then why isn't there a hyphen? Think I'm missing something here. Though to be honest I'm not sure the answer you're looking for exists without the use of InDesign – Ryan Jan 25 '16 at 21:51
  • @Ryan In the "Paragraph" window there's a "Hyphenate" option, I've unchecked that – Downgoat Jan 25 '16 at 21:52
  • What happens if you use a non-breaking space (ASCII 160)? – Andrew Leach Feb 25 '16 at 9:57
2

To answer your question what you're looking for doesn't exist in Illustrator. The only, really hacky, way to do what you're after would be to use an n-dash (or any other available symbol really) with no fill and no stroke.

If your text is long it might save you some time doing a Find and Replace in a text editor / desktop publishing program to make the spaces into n-dashes before pasting it in.

0

All the alignment options seem to be creating that line break, except for the Justify alignments which also leave lots of gaps between the characters. But if its okay with you, tweaking the text by leaving a space btween the d and f(in the place of the *) asdfjkasdfasdf asd*fadsfasdfasdfasdfasdfa. This pushed the characters following that space to the next line and produce your desired effect.

  • Unfortunately this isn't a viable solution for me as I have large blocks of text (I'll be changing the contents), and doing this over and over would be extremely time consuming. – Downgoat Jan 25 '16 at 20:24
  • Oh, now that is tricky, how does leaving a Justifying the text appear to you? Can you live with that gaps between the characters? – iamcastelli Jan 25 '16 at 20:29
  • Justifying it adds waaay to much space, so that won't work for me. – Downgoat Jan 25 '16 at 21:10
0

Select the "fa" and then from character menu use "no break". Illustrator help mention "non-breaking space" but only how to see them not how to put them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.