I was inspired by the table of contents in this document and set out to mimic, in a document of my own, the way the page numbers fall before the text in large numbers each with two digits (e.g. 01 instead of 1). I'm fairly familiar with creating and managing a TOC in InDesign but I can't figure out how to do this. I've tried using Drop Caps in the TOC paragraph style and that gets me the large number, but I can't figure out how to get the numbers to format as 03 instead of 3 (with a zero in front of single-digit numbers).

Any suggestions? I tried adding a numbered list to the style (where I know I can use a 01,02, etc. format), but of course that only gives me a numbered list 01, 02, 03 instead of the pages the text refers to (e.g. 03, 09, 17). Thanks in advance for your help.

  • Are your pages numbered the usual way? (Because 1. usually the TOC's numbering follows the actual document's, and 2. single leading zeroes are an option in modern versions of InDesign.)
    – Jongware
    Jan 27, 2016 at 20:43
  • I think they're numbered the usual way. For example, I'm using text variables and special characters to have "Page 5 of 20" appear on the bottom of my pages. Is there a global place, like in preferences, to change numbers so they use 05 instead of 5? Jan 27, 2016 at 21:09
  • That is covered in the Online Help - check the options in the Style dropdown.
    – Jongware
    Jan 27, 2016 at 21:13

2 Answers 2


Thanks @jongware, that did it. In case someone else finds this thread in the future, here's what I did:

  1. Clicked the first page in my doc
  2. Went to Main Menu Layout > Numbering & Section options
  3. Under Page Numbering, choose 01,02,03 etc. from the dropdown

Thanks Peter, I found this thread and your concise directions made this a snap. Dropped the three-digit page number marker on the parent page and I was off to the races. Note that if you are using Data Merge and preview any page in the page range of your document, the preview will not update the page number, exporting to PDF from the Data Merge options doesn't appear to work either. In order to see the page number correctly update, you have to render a merged document. Thanks again!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.