4

So I am working on a Mac with Magic mouse. When I am using the Adobe programs (Ai, Ps, Id, no matter, I think it is common for all of them), if I accidently hold the alt button and move my hand on the mouse, I zoom in/out. It is unintentional, and it is happening to me quite too often, so I need your help.

I want to disable it, but when I search the software shortcuts menu for zoom shortcuts, I don't find the alt+scroll command. So I don't know how to remove it and I don't want to deactivate the scroll on my OS from the system preferences.

Just to mention that my "Zoom with Scroll Wheel" box in the Preferences - General in Ps is unchecked.

Any ideas?

  • Its hardwired you can not disable it from the GUI. Its possible that theres a hidden settings somewhere contact adobe support. – joojaa Jan 28 '16 at 12:42
  • When I started using Magic mouse, I had the same issue, although it was with scrolling. The viewport would suddenly just fly far from the artboard. Multiple times a day, but eventually I got used to using the mouse and it never happened again. ---- You could perhaps disable alt + mouse scroll in adobe applications by using Karabiner. They even have example code for disabling the scroll wheel in Magic mouse altogether, but you can also specify applications and modifier keys. Modifying it could work. – Joonas Jan 28 '16 at 13:05
  • How do you even accidentally hold down the alt key? – PieBie May 31 '16 at 19:52
  • @PieBie this happens to me all the time. When you are resizing an object, for instance, and you hold down Alt to scale from its center, you can wind up zooming way off the page if your finger even slightly moves on the magic mouse – Manly Feb 17 '17 at 16:48
2

It's a combination between using Magic Mouse and Preferences in Adobe.

So when

Edit > Preferences > General > "Zoom with Scroll Wheel" is checked, then the Alt + scroll is disabled. But when you uncheck the option of "Zoom with Scroll Wheel", then Alt + scroll is enabled.

So you could leave the "Zoom with Scroll Wheel" checked and change/disable scroll wheel in Magic Mouse.

System Preferences > Accesibility > Mouse & Trackpad > More Options [here is the link]

  • But leaving my scrolling in System Preferences unchecked disables my scrolling on the OS. So I need scrolling in the OS, and even when I uncheck "Zoom with Scroll Wheel" I still have the accidental zooming in the Adobe software programs. – Serdica Mea Roma Est Feb 10 '16 at 14:47
0

I have this issue with CS6 Suite on a MacBookPro running 10.8 (and some other apps).

Simple answer (none system preference as requested)

Add an additional none 'Magic' mouse to your rig using a USB port (I use a wired Apple laser mouse circa 2007). Keep your wireless Magic Mouse for general OS use and web browsing (scroll effects operate), and when you go into CS pick up the other mouse - you will enjoy a scroll free experience without changing anything on your OS as this mouse cannot physically scroll. The two mice will not conflict with each other (the joys of Apple).

It may feel strange at first to have two mice on one Mac but try it - takes a second to reach for the other one and will become second nature quickly. You can get the older Mac mouse on eBay for about $20.

Hope this simple, none tech solution helps.

0

I don't have a perfect solution, but if you install BetterTouchTool you can use it to deactivate option + vertical scrolling only in Illustrator. Unfortunately, there does not appear to be a feature to restrict opt + horizontal scrolling in specific apps, but I find (at least personally) that most of my accidental scrolls are vertical, anyway.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.