0

When I save and then open a file with Inkscape, it loads with object dislocated. I can then fix the object's location (it jumps near correct location after even slight move), save, but after opening again the situation repeats. The original file is

https://github.com/psprint/zplugin/blob/master/doc/img/zplugin.svg

The effect of loading is below:

Inkscape after opening file

1
  • I clicked the github link and it looks like the issue is resolved. If that's the case, could you accept the answer? If it's not resolved, can you elaborate? Commented Aug 8, 2016 at 11:45

1 Answer 1

1

In XML code there is a translation command that moves the cube. You have to remove it.

Inkscape after opening file

You can also remove it selecting the cube's and setting its coordinates to x=0 and y=0

enter image description here

7
  • Tried both options and neither worked. Here is what I did manually: imageshack.com/a/img922/6775/xhwGTl.png Commented Feb 9, 2016 at 16:11
  • 1
    I used XML editor inside Inkscape (In Windows Shift+Ctrl+X). Then select "transform" and delete the value in the botton on dialog windows. This way I solved.
    – WalterV
    Commented Feb 9, 2016 at 16:43
  • Doing what you wrote (via Inkscape XML editor) indeed instantly moves the object where it should be, however after saving and opening, it's still the same dislocated Commented Feb 9, 2016 at 17:23
  • @VolkerAmnu, I dont Know... I "saved as" in inkscape svg and pure svg. In both cases reopening the file, it's ok...
    – WalterV
    Commented Feb 9, 2016 at 17:36
  • Maybe you could upload the fixed file somewhere? Maybe it will work for me too Commented Feb 10, 2016 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.