I am trying to export a large AI file to PNG in Illustrator (Per request) and have been unsuccessful. I believe it's because my file is too large. I'm hoping someone can shed some light on how I can export that large file to PNG?

  • 2
    What happens? Do you get any errors or messages?
    – Miro
    Feb 12, 2016 at 20:51
  • Do you have access to Photoshop? I know this doesn't answer your question directly, but that may be the easiest approach. Open the AI file there and then Save for Web as PNG or do a File> Save As as PNG. Feb 12, 2016 at 20:57
  • 1
    "unidentified error" is the message that I get. Feb 12, 2016 at 21:00
  • I do have Photoshop, I did try to save for web .. however it would not let me in Photoshop either. Feb 12, 2016 at 21:01
  • 1
    A temp solution that might work is save as a PDF with "Preserve Illustrator Editing Capabilities" unchecked, then open the PDF in Photoshop and save for web as a PNG.
    – AndrewH
    Feb 12, 2016 at 21:40

4 Answers 4


A quick bypass would be to use inkscape instead. Download it from here: https://inkscape.org/en/

Inkscape can open large .ai files, and also can export them as .png
The only thing that you should do is:

  1. Open your file with inkscape

  2. Go to File > Export as PNG

  3. In the window that pops up, select Page

  4. Then in the same window choose where should the file be saved

  5. And hit export

That's it


You need to define how large is large. And what is the "Per request".

If someone asked for a 10 m wide png at 300 ppi, most likely your computer won't handle it. (If someone asked that kind resolution they do not know what they are talking about)

Try to export a smaller file:

  • Defined pixels: for example a 10,000 px wide (or height). Choose the larger value.

  • Lower resolution. For example a 10 m wide at 25 ppi (wich wil be simmilar to the 10,000 px total width.

There are several posts on the forum regarding big files. Take a look: https://graphicdesign.stackexchange.com/search?q=resolution+for+print


It might also be because of illegal file naming. You can't use / © ™ etc… Anyway, that was my problem and how I got to this thread… Maybe it will help you.


There is another solution, you unlock all the layers of your document, then go to the file bar and select the option "export selected" and it should work just fine, it worked for me :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.