I am fairly new to photoshop, and I was drawing images for a client's wedding invitations today. The image I created was white, and it wasn't clear enough against the backdrop, so I tried to increase the stroke size around it.

That part worked ok, and it outlined the image in black.

When I attempted the change the outline to white, something odd happened. The image became rainbow colored. And I have about 10 images it did this to. . . My image has been rainbow-fide!

WHAT IS GOING ON?! I just want the images outlines to be thicker, so they stand out against their watercolor backdrop.


  • 4
    It will be helpful if you could provide several screen captures of your entire Photoshop window. I wonder if there might have been an accidental change in brush or layer blend modes.
    – user45605
    Feb 13, 2016 at 14:30
  • 1
    Looks like bad RAM or a corrupt HDD to be honest.
    – Scott
    Feb 17, 2016 at 18:56

3 Answers 3


Without actually seeing your document. It looks to me like you might have accidentally changed the blend mode of your layer. I am thinking that is might have been changed to hard mix. In your layers panel check that your blend mode is set to normal and this should fix your issue.

This shows the blend mode set to "normal"


Same here. Think it has to do with GPU rendering. It only happens when the resampling algorithm is set to Automatic. When choosing it manually, the colors stay normal.

So, the work around for me is to manually set the resampling drop down choice.


I suggest to check the blending option, set it to normal and if still the case persist.its your PC GPU problem just take a help from hardware engineer and go check it.

If you are new ,then it's good if you know that photoshop and illustrator works on layers basis. So, double check., It might be Possible that you put something called blurry or rainbow canvas over your working layer.

  • What's a blurry or rainbow canvas? I never heard of this before.
    – Luciano
    Jun 7, 2019 at 13:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.