1

I have Gimp 2.8.16. I have repeatedly attempted to create a transparent background for a simple image with a white background. I have tried this tutorial http://docs.gimp.org/en/gimp-using-web-transparency.html and this tutorial from StackExchange Making the background of an image transparent in Gimp . I have used .png and .jpg images; neither type works: the png automatically has an alpha channel; the jpg image needs to have an alpha channel added.

I have followed these tutorials to the letter; yet, the alpha channel never shows up as transparent; it is always white. If I hide the alpha channel in the channels dialog, the entire image disappears. If I either save it as png or export as png and reopen it, the image is completely white!

Is this feature buggy in 2.8.16 or does the process differ in this version from earlier ones?

What is even more irritating is that I opened the same png image in Krita and was bale to remove the white background in seconds creating a transparent background. Closing and reopening hte image in Krita showed the transparency; opening the same transformed image in GIMP showed me a non-transparent image with an alpha channel that if hidden removed the image completely even though the rgb channels showed the image.

I closed and re-opened GIMP and opened the "transparent" image (transformed in Krita) again. this time I created a new layer behind it and changed its background: the "transparent" now showed the new background.

Has GIMP changed the default background to white and no longer shows if an image has transparent areas?

  • 1
    You do not need to touch the channels dialog at all for this in any case - you're adding an alpha channel to an individual layer, that is only remotely related to the - even slightly misnamed - alpha "channel" in the channels dialog. If we had to redo this dialog now, we'd use "component" instead of "channel" and wouldn't put them there, either. – Michael Schumacher Feb 19 '16 at 0:01
1

Solved my problem: Opened Edit >> Preferences, selected Display, under transparency selected "light checks"; the background for the image instantly changed to the classic checked style and the transparency of the background could be seen.

  • 1
    That is not the default setting, though. Any idea how and when you might have changed this to white? – Michael Schumacher Feb 18 '16 at 23:59
-2

Too many experts that don't know what the heck they're doing. Quit confusing us! Go to Layer and in that dropdown menu you will se "transparency". Go to that one and there you will find the alpha channel.

  • Hi Ben, thanks for your answer. What exactly are you trying to say? What is the added value in the first two sentences? – PieBie Nov 12 '18 at 8:48
  • Are you an expert? I am confused... :o) – Rafael Nov 12 '18 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.