1

I learned a way to use Blend Tool to create shading effect for flat logo design.Here I put same adjustments as the tutorial does, but my shading is not smooth for some reason. I am guessing it's a setting problem but have no idea how to fix it. It would be great if somebody know about how to fix this!

It's supposed to be like this

But mine turned out to be inconsistent

  • have you tried changing to "Smooth color" in that same box where it says "Specified Steps"? – Luciano Feb 25 '16 at 12:32
  • I couldn’t reproduce your problem, so it might be a bug. Does increasing the number of Specified Steps make any difference? Sometimes the GPU preview can cause artifacts, so you could try View > Prieview on CPU – mnxd Feb 25 '16 at 22:01
  • You need to either specify more steps, or move the two items slightly closer together before the blend. The tool is placing 80 copies evenly spaced. This is leaving a gap between each item. – Yorik Feb 25 '16 at 22:19
3

It's as easy as it can get, the number of steps you set is equivalent to the number of cloned shapes between the two (as you can count for yourself in the 10 steps example below, there are 10 clones between the two primary ones) so it's only logical that the more cloned shapes you have between the better it will look. So play around with the number of steps like I did below (go even higher than 1000 if you have to) :

enter image description here

Best of luck !

PS: You should also try and apply this blend mode to a single shape, as I saw in your shadow you applied it to a group of shapes. First unite all the shapes and give it ONLY THE FILL COLOR (no border color) you want your shadow to be and only then duplicate it, change the opacity to the second and apply the blend mode. Looking at your shadow I have a hunch those yellow lines might be caused by a yellow stroke on one of your objects.

2

If I'm understanding correctly, it's a very simple fix. Simply select 'Smooth Color' for the Spacing instead of specifying 80 steps distance.

Alternatively, use far more steps, maybe 512 or max 1000.

  • Smooth Color option gives only a single half-dark shape in the middle rather than an extending shade. Also I changed the input to a wide range, still producing the inconsistency :( – Lori Fu Feb 25 '16 at 21:15
2

When you blend from opaque to transparent, each step is slightly more translucent... so you will see underlying steps.

If you start with a translucent object and attempt to blend to transparent, the issue is worse.

If your blend steps are not a high number, the issue is worse.

Additionally, in your case, it appears as though the "to" or bottom right shape is higher in the stacking order than the center (dumbbell) shape. So, you are stacking translucent objects onto more opaque pieces... making it worse. Appearance may be better if you moved the "to" shape lower in the stacking order.

The best way to address this is to blend opaque objects of varying fill colors rather than using transparency at all. And place the "to" shape below the shape casting the shadow, not above it.

For example, your image could blend from grey to yellow. You can then expand the blend and remove the unwanted pieces -- or just apply a clipping mask on the blend.

It's also much easier to apply a directional gradient in many cases rather than using a blend.

0

Or you can Unite the steps (from Pathfinder) and manually delete the anchor points. But mind you deleting those points can be a pain in the **s if you have too many steps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.