1

I use Inkscape for work, and I often have to import curves from .ps or .pdf file to then fit them into a schematic or a scale. The problem is that I often have no control on the ps/pdf file, and if I must significantly rescale the curve, it exhibit different stroke widths. I can easily create another path using :tool_node: that follows almost exactly the original path, but this is a inelegant and time-consuming process. Therefore, I am looking for a way to make a non-uniform stroke uniform, e.g with the same width accross the whole curve.

enter image description here

I have included the example above here, in hope it helps.

3
  • 2
    Your path is in a group with a transformation matrix applied (hence the calligraphic effect). Try to ungroup it or to remove the transformation. And the path is full of unconnected vertex too. Try to write your own answer, now. Feb 27 '16 at 10:00
  • 1
    Thanks a lot. Ungrouping does work, but how do you see whether a transformation matrix is applied ?
    – HcN
    Feb 27 '16 at 15:11
  • The fastest way is reading the XML source. Feb 27 '16 at 21:20
1

Deactivating when scaling objects, scale the stroke width by the same proportion should do the trick for you:

enter image description here

2
  • Thanks for your answer, but this is not the issue here. When importing a path from a PDF, it apparently comes in a group with a transformation matrix that affects the stroke width. As a result, the stroke becomes non-uniform when rescaled, whether this option is enabled or disabled. A solution here is to ungroup then to regroup everything again, as indicated by @Paolo Gibellini.
    – HcN
    Feb 28 '16 at 0:35
  • 1
    @HcN: Still, what I described circumvened the problem for your example file for me.
    – Wrzlprmft
    Feb 28 '16 at 6:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.