I am trying to change the stroke width of an icon in Inkscape but, unlike other times I have done this, this time the stroke width appears to be 0 px and I am not allowed to make it thinner:

enter image description here

The stroke width is actually quite large already, is there another setting I should edit to make it thinner?

You can download the file I am working on here.

BTW: sorry for the potato quality of the screenshot, this is what you get using Inkscape on a retina screen :/

  • Can you put a screenshot of the object you're drawing? I suppose if the stroke width is 0 it will be invisible? What effect are you trying to achieve?
    – Luciano
    Commented Mar 7, 2016 at 15:15
  • Are you trying to change the stroke of a path or of a group? For a group 0 px is an expected value. Have you tried to enter a value and hit the return key? Tell us something about your efforts, please. Commented Mar 7, 2016 at 15:24
  • 1
    @PaoloGibellini when I select the object, at the bottom of the window I see "Path 11 nodes in layer", so I think it's a path. When I enter a value and press Enter, the value is reset to zero. If I click on the up arrow in the stroke width section, the value goes to 0.100, if I press it again it goes back to 0.000. Commented Mar 7, 2016 at 16:10
  • I had a similar problem, where I couldn't type in a value in Stroke Width - it would always go back to zero. Turns out I had to go in the Stroke Paint tab and add a stroke first before I could add a Width. Commented Aug 9, 2018 at 23:47

5 Answers 5


In your file we have two (or three) nested problems.

The first is related to the group: for a grouped object we see 0 px as stroke value:


Your icon is nested in a series of groups, and you have to hit Shift-Ctrl-G repeatedly until done:


The stroke width is 0 px again, and in this case is correct, because your path is composed by an outer and an inner section, with a 0 px stroke and a black fill:


You can break apart the path:

break apart

Now, you can remove the inner path and add a border to the outer one:

a border

  • 1
    Thank you for the extensive explanation, worked perfectly :) Commented Mar 9, 2016 at 13:53

You'll get similar symptoms unless you pre-select a stroke paint (initially set to none). I wonder why Inkscape could not warn about this instead of allowing the up-arrow adjust stroke width to go from 0.000mm to 0.100mm and have it magically jump back to 0.000mm...


If you're trying to draw a simple shape with no fill, just the border, but inkscape will not allow you to change the stroke width, ie stroke width keeps going from 0.1 back to 0.0 click the dashes drop-down menu and scroll to the bottom. You should see solid lines try one of these and then try changing the width, it worked for me:)


We had the same issue at Maker Works. Until we realized that problem was that I was trying tocreate something that was 1/100th of a pixel. Which is impossible. Once i switched to inches, it worked


I discovered this problem only on my laptop and I then realised I didn't have the number lock on. Every time I tried to change the stroke to below 0.100 mm it just kept reverting to 0.100 mm. I then used the numbers along the top of the keyboard and it changed the values okay. It was then I realised that the number lock was off. I tend to only use my PC for inkscape and it's not an issue I had encountered. I needed a stroke of 0.080 mm for setting up my laser cutter, because 0.080 mm is the diameter of the laser beam.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.