1

I'm a bit puzzled because I'm not able to register any python script in Gimp (2.8). I've tried to follow the docs there are two complete examples, clothify and echo, I've tried to put both on my ~/.gimp-2.8/plug-ins/ but they doesn't seems to get registered. At the end of the page there is the test using console invocation and I got:

batch command experienced an execution error:
Error: ( : 1) eval: unbound variable: python-fu-console-echo 

I've tried with other plugins, and restarting with a new ~/.gimp-2.8 dir

What do you suggest? (I'm on Ubuntu 15.10)

closed as off-topic by Zach Saucier, Vincent Mar 15 '16 at 14:26

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This appears to be a tech support question about fixing technology to work as advertised. Please edit the question so that it pertains to using technology to solve a design problem. You may want to check if it hasn't already been asked in Super User. In many cases, contacting the manufacturer is the quickest option." – Zach Saucier, Vincent
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Got downvoted? I see many questions on gimp here got downvoted maybe because there is nobody able to reply? Someone just hate it? – diramazioni Mar 12 '16 at 7:46
  • I don't know why someone downvoted such a question without a comment. Perhaps because your question is more related to the installation of the application and more suitable for SuperUser? – Paolo Gibellini Mar 12 '16 at 10:41
  • Downvotes happen if something isn't about graphic design - basic usage of the applications is offtopic here. There's SuperUser for that. – Michael Schumacher Mar 12 '16 at 10:41
1

I've discovered the reason why the plug-ins didn't get registered: apparently the file need to have the execution bit

chmod +x plugin.py

Hope it helps someone who stumble upon this problem in the future

  • Hi diramaziono, don't forget to mark your answer as accepted if it solved your problem. This prevents it from showing up in the feed and list of unanswered questions! Thanks – Cai Mar 12 '16 at 10:27
  • it says I can accept my own answer in two days. Maybe there are other way to mark as solved? – diramazioni Mar 12 '16 at 12:53
  • No problem. I don't think there is any way around that. Just wait two days :) – Cai Mar 12 '16 at 12:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.