6

Been trying to search for an answer online for quite a while now but can't seem to find anything new. I'm familiar with layer styles and I've been merging them down to rasterize a layer, but for some reason none of this logic seems to be of any help with this particular case; Although a familiar concept, I must admit that I have never used layer styles to this degree, so the amount of variables is what gets me lost.

Photoshop CS4 Extended, Mac OS. Image dimensions 4000x4500px at 300dpi.

I was practicing with layer styles, mostly creating layers with flat single-colored areas of shape and experimenting with the settings. I ended up creating several layer copies with the same blobs, setting layer Fill to 0%, then applying different styles to them to create whatever is visible. Some style settings cause the blob to expand over the original shape's dimensions which I don't want, which calls out for a layer mask. But if you apply a mask directly to the layer, the style itself is affected by the mask boundaries, not just what you see, as would happen in case of normal pixels. As a workaround, most styled layers had to be placed into folders, and the mask stencil applied on the folder instead of layers. Actual layer fill set to 0% is because I was working with glassy objects and I wanted to focus fully on what the styles alone do.

All looks nice when the .PSD is open in Photoshop, but from there on, nothing seems to work. The image always ends up looking completely different when trying to export it into flat form. Especially light effects like bevel just seem to get baked to the image as full-on burnt white, even though the light that I'm seeing in Photoshop is subtle, three-dimensional, graded and translucent. Layer>Rasterize is greyed out. These are all of the things that result into an incorrect rendition:

  • Max quality .jpg
  • .png
  • Finder thumbnail of the very same .psd file that looks good when open in Photoshop
  • Merge visible
  • Merge layers
  • Flatten image
  • Convert to smart object
  • Merge down, when the layer below the selected styled layer is empty and unstyled
  • Happens in both cases, when the background is transparent, and when it's filled with 100% opaque pixels.

I had to take screen captures to get the image to compare. Left: Every time a render, this happens. This example is without a background. Right: In Photoshop, the item floating half over opaque pixels and half transparency.

enter image description here

  • A sample will help me better understand what you are describing. Something like a screen capture in Photoshop and then JPEG as exported. – user45605 Mar 30 '16 at 20:10
  • @ACEkin Right, added! – user158589 Mar 30 '16 at 21:37
  • That is truly odd! Neither side resembles the original. One thing you can try it to merge layers starting from the bottom and gradually go up merging the next layer down, and so on. If you end up with the wrong look on the right at some point, it will tell you more. If you do not, then save or export the image as a JPEG file. If that shows the abnormal behavior, then it will tell you even more. – user45605 Mar 31 '16 at 1:04
  • @ACEkin the coarse look on the left is the bad rendering that I don't wish. The half/half one is from Photoshop, what I'd want to see when saving and merging. I have indeed tried to create an empty layer under one of the styled ones and merge down just one at a time, but then I still get that ugly transition happen in front of my eyes, now it will just happen per piece instead of all at once. – user158589 Mar 31 '16 at 7:23
  • 2
    Well.. I can tell you the difference in rendering appears at higher zoom levels — recordit.co/383Znu7qt2 — it seems to be anything with lighting involved, bevels etc. Also it doesn't happen at all if you reduce the image size, which makes me think its a performance issue. – Cai Apr 1 '16 at 15:54
1

This is zoomed preview rendering issue in Photoshop. What you see when your artwork is zoomed to fit your screen (not 100%) isn't accurate and your flattened/rasterized image on the left in your example is actually what your artwork looks like.

When viewed at 100% you'll see that the effects stay the same before and after flattening/exporting/rasterizing.

When not viewing at 100% photoshop uses a different (faster and less processor intensive) method to render the layer effects for preview. Most of the time it works well, but in this case it seems to greatly affect the bevel and emboss layer effect.

Unfortunately this means that your artwork really looks the way you don't want it to.

To fix it you're going to have re-adjust all your layers while working at 100%

or...

Go to Preferences-->Performance---History and Cache Set Cache Levels to: 1 Quit and Restart Photoshop.

Now you'll see a more accurate preview at all scale levels, but with a performance penalty.

Here's a post on the Adobe forums discussing a similar issue.

https://forums.adobe.com/thread/1112285?tstart=0

  • doesn't seem to be the case here – Luciano Apr 1 '16 at 16:20
  • It works for me. Open the file, view at 100%, merge layers. The image doesn't change. – Mysterfxit Apr 1 '16 at 16:26
  • 1
    @Mysterfxit which is exactly why I'm assuming it's a performance issue. It behaves differently for me on 2 different machines. – Cai Apr 1 '16 at 16:37
  • I don't think it's really a performance issue. It's just that the method photoshop uses to render a preview at different zooms in the workspace - some kind of shortcut that's faster less and less processor intensive - is different than when it actually rasterizes the effect and yields a different result. The way it looks at 100% is the "real" artwork. – Mysterfxit Apr 1 '16 at 16:49
0

I opened your PSD. I see you use several different blending modes in the effects.

Blending modes depend heavily on the layers below it to render the image, so I suspect you won't be able to merge the layers accurately keeping the transparency and the effects.

One solution would be to change the blend modes to normal in the effects, rebuilding the image differently.

  • All layer blend modes are set to normal and the groups are set to Pass Through. – Mysterfxit Apr 1 '16 at 17:39
  • 1
    the layer effects blend modes are not set to normal – Luciano Apr 4 '16 at 8:10
0

That's a problem with no issue. After trying, I hided all the layers except the layer with the layer style, and I make a screenshoot with the snipping tool of Windows. I put a black layer behind, export and import the image and apply a screen fusion mode. That's the only solution I found. Good luck!.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.