2

When I add rows to a table in InDesign, the paragraph style changes and adds "+" to the paragraph style name. My text then changes color (from black to blue) and a yellow highlight is added. I have to manually fix this, which is tedious.

How do I add rows without the paragraph style being affected?

2

Without looking at the file itself, my best guess is that you have a trailing whitespace at the end of the cell, which has the mentioned formatting applied to it.

When inserting new row(s) in table, InDesign copies the paragraph and character style settings (along with any overrides) of the cell over to the new ones it that same column. More specifically, it copies the settings of the last character in the cell, be it a letter, whitespace, or even a break character.

Check Show Hidden Characters under the Type menu (it sits at the bottom) or press CMD + ALT + I if you're using Mac or CTRL + ALT + I if you're on a PC. See if there is any symbol at the end of the cell, similar to ones in the screenshot below. There should be only a hash # symbol at the end of each cell, like in the first cell in the image. If there is something else beside it (or if there's only a symbol other than #), it is most likely that character which carries the unwanted formatting, which then carries over to new rows.

Various types of hidden characters at the end of table cells in InDesign

If you want, you can try selecting it and checking which overrides are applied. Otherwise, you can just clear the overrides. Click on the Clear overrides button at the bottom of Paragraph Styles panel, or CMD + click (CTRL + click on PC) to clear only the character overrides, keeping any paragraph overrides.

Clear Overrides button in Paragraph Styles panel

For a more "permanent" solution, check if there is a cell style applied to a cell. If there is, this style might have a paragraph style selected as default. Either change the cell style or paragraph style settings to your liking.

0

You must have a different paragraph style selected as default, which will cause the style to switch back to the default when moving to another column or when adding more rows in your table.

There are a few things you can do to approach this correctly, however the easiest thing you can do is:

  • insert whatever you need in your table (rows, content, etc) and ignore the formatting issue
  • double check you have inserted everything and again ignore the formatting issue
  • when you think you are done, select all the rows with the issue (or the entire table) and with these selected, right click the correct Paragraph style in the panel and click Apply or Apply + Clear Overrides, which also removes any possible trailing Character style that could affect your formatting
0

Select the table. Hold down alt and click the paragraph style that's a problem. This should override any custom settings in the text currently.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.