EDIT: TL;DR I can't get rid of anti-aliasing and/or feathering, even though they are disabled.

Some visuals, so you can actually see it happen...

First this is me trying to erase, clicking madly; http://i.imgur.com/lmURwvM.gif

The next is attempting to fill the selection using the pencil; http://i.imgur.com/6ILgU83.gif

Finally, a pic of the results of a simple 'fill' (100% black); http://i.imgur.com/1gs4i0t.png


Detailed explanation;

I am working with images that require that there be no anti-aliasing or feathering of any kind. The 'jagged' look you can see in the image (end of post), where I have managed it, is the desired result. Photoshop seems to force gradations on me despite attempts to eliminate them.

I have attempted the following settings;

  • Brush hardness and opacity of course at 100%
  • Anti-alias unchecked, presumably disabled
  • Feathering set to minimum possible (.2)
  • Edit -> Preferences -> General > "Image Interpolation" set to "Nearest Neighbor (preserve hard edges)" (though I gather this is more for preserving pixel appearance when resizing, thought I'd try it anyway)
  • possibly other things I've forgotten...

All of these settings to no avail, as Photoshop simply will not let me draw (or erase) cleanly within a selection. It insists on creating partially opaque pixels surrounding every pixel I am working with, both in and outside of the selection (even when working with a single pixel at a time). The tool I'm using doesn't seem to matter - either brush, pencil or eraser. The method of selection doesn't appear to matter either.

Erasing a single pixel requires some half a dozen clicks as it is gradually erased, partially erasing all of its neighbors as it does so. Say, 80% transparency the first time I click, 60% the second, and so on, meanwhile making all adjacent pixels reduce to partial trans. as well. It's maddening. Can I not simply click on a pixel and have it gone, while NOT simultaneously effecting its neighbors? And can I not simply draw a single pixel (in or out of a selection) and have it 100% opaque, while also not effecting adjacent pixels? What is this behavior, and can it be stopped?

Repeated Google searches havn't answered this for me. Bottom line, what do I need to do to completely stop any and all anti-aliasing and/or feathering, and simply draw a solid, 100% opaque image within a selection?

Example image can be seen here;

example image

  • What exactly is CS? – Cai Apr 17 '16 at 16:08
  • Is CS the Adobe Creative Suite? – Somatic Apr 17 '16 at 18:15
  • Sorry, the software is Photo CS Extended - simply, Photoshop. – Brad Apr 17 '16 at 18:19
  • How are you creating your selections? All you should need to do is set feathering to 0 (I'm not sure why you say minimum is 0.2?). I just tested and I can't reproduce your problem. – Cai Apr 17 '16 at 19:59
  • Possible duplicate of How can I stop or disable anti-aliasing / feathering in Photoshop? – Cai Apr 17 '16 at 20:10

Create a document 800px X 600px and set resolution to 10 px/in

enter image description here

You can still see anti aliasing on hard brush stroke.

Undo that

anti aliasing

Now change Image Mode to Index Colour

enter image description here

Select Palette to Uniform

enter image description here

Now painted with hard brush with no effect of anti aliasing or semi transparent pixels.

enter image description here

| improve this answer | |
  • 1
    What does setting the document resolution to 10PPI have to do with anything? – Cai Apr 17 '16 at 22:51
  • lower resolution for more jagged edges, higher resolution will decrease the jaggedness or adjust resolution as per required. – Ravi Joseph Apr 17 '16 at 23:01
  • Not really—800x600px at 10PPI is exactly the same as 800x600px at 300PPI. Pixels is all that matter. – Cai Apr 17 '16 at 23:06
  • Yeah, both will be same as pixel count didn't change. For dimension, I should have taken inches or millimeters :) – Ravi Joseph Apr 17 '16 at 23:25
  • I'm afraid to use indexed color, you have to flatten first (i.e., you cant use layers). I am working with layers. – Brad Apr 18 '16 at 1:46

If you are using the any of the Selection tools, all you need to do is set Feather to 0px and un-check Anti-alias:

enter image description here

If you have a selection with a feather already applied to it (for example, if you use the 'Make Selection...' command on a path there seems to be a minimum feather) you can use Refine Edge (Select → Refine Edge...).

enter image description here

Setting the Contrast to 100% will give you a hard edge with no feathering. It may not be perfect but if you are stuck with a feathered selection it is the best you will get without manually remaking the selection. You may be able to adjust the other settings to get a better result.

enter image description here

A better option (as @joojaa pointed out) is to enter Quick Mask Mode (Q) and use Threshold (Image → Adjustments → Threshold...)

enter image description here

| improve this answer | |
  • 1
    Well yes i prefer to page to quick selection mode and use threshold, because i can adjust the cutoff value. – joojaa Apr 18 '16 at 11:13
  • 1
    Yes, you are right, threshold is a much better option! – Cai Apr 18 '16 at 11:15
  • Threshold did the job! I was trying to do a Color Range selection, and it was giving me a lot of feather. Thanks – Shayan Jun 17 at 11:21

It turns out, at least for this particular pic, that the issue was the pen tool. I was using more than one tool to do some fairly intricate selections, but they began with 'pen tool>make selection'. There is an option that pops up during that process where both anti alias and feather options are, that I completely missed. Anti alias was checked. So far, making the adjustments there (unchecking it) is working for me. Thanks everyone for the suggestions!

| improve this answer | |

Do this: enlarge the image by 10x, and reduce the size of your selection circle a lot.

The selection-circle-to-pixel-size ratio automatically controls the amount of feathering applied at a soft edge. I don't like it but that's the way photoshop is at the moment. You will have to zoom in and be more precise with the way you outline with the selection tool but at least you won't get a soft selection. Photoshop is trying to be intelligent and match the natural ambiguity of the edge that it detects. I guess that is good in some cases but I agree there really should be a way to finely control it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.