When I have my tablet plugged in, "Step Backwards" and "Undo" stop functioning normally. I have CS5 Extended 12.1 64-bit and OS X 10.7.3 with a Wacom Intuos PTZ-630.

Suppose I draw 3 discrete strokes with the stylus. If I hit "Step Backwards", I would expect the most recent stroke to immediately disappear. But it doesn't. However, as soon as I do anything (such as press the stylus tip to start drawing again), the stroke disappears! If I hit "Step Backwards" again, that stroke and the preceding stroke seem to disappear simultaneously.

Clicking & dragging the window for the image "counts" in terms of causing a screen update. So if I hit "Step Backwards", nothing will happen, but then as soon as I move the window even one pixel by clicking & dragging the top bar, it will take effect.

Hitting "F" to go into full-screen mode makes the problem go away. Both full-screen modes (there's one when you hit "F" the first time, and another when you hit it again) fix it.

Anyone experienced an issue like this?

  • Just to be sure, this only happens when you have your drawing tablet plugged in?
    – Joonas
    Apr 15, 2012 at 7:44
  • Correct, Lollero. Though if I unplug it, the problem persists in Photoshop until I quit and restart the app.
    – Max Cantor
    Apr 15, 2012 at 21:43
  • I'm unable to replicate the issue with Mac OS 10.6.8 and an Intuos 5 (PTH) or an Intuos 4 (PTZ) tablet.
    – Scott
    Apr 15, 2012 at 22:21

1 Answer 1


The most likely source is an unforeseen interaction between the GPU driver and the tablet driver, since it's a screen refresh issue.

The problem might be caused by Photoshop's GPU usage. The extra load placed on it by the pen input might be triggering the defect. Try each of your GPU acceleration settings (Advanced, Normal, Basic) in turn to see if there's one that makes the problem go away. The setting is at Preferences > Performance. Click on the "Advanced" tab to find it. You'll have to quit and restart Photoshop each time, to make the change effective.

If that doesn't fix the problem, trash your preferences (hold Cmd, Opt and Shift while the program is loading) and try again.

If that STILL doesn't fix the problem, report it as a bug to Apple and Adobe.

  • The only available choice was "Basic" (the dropdown was grayed out). I had previously tried completely un-checking "Enable OpenGL Drawing" to disable GPU drawing completely, but I thought it didn't change anything because I didn't know I had to restart Photoshop. However, the issue is now resolved after restart. (I guess my GPU isn't beefy enough to even have the Normal/Advanced options available.) Thank you!
    – Max Cantor
    Apr 16, 2012 at 1:37
  • You're welcome. I (and others) went through numerous gyrations with GPU acceleration in the CS4 and CS5 betas, changing modes to find what worked best in different configurations on different machines, so it was a good bet that the problem lay in that area. Apr 16, 2012 at 7:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.