2

I'm using the text tool, I type some text but it types in all white. I go to highlight the text and change the color to black, at the top of the screen on the toolbar, and the color won't change.

I'm just poking around with everything that even looks like I could change the color and it's still white.

migrated from photo.stackexchange.com Jan 28 '11 at 16:35

This question came from our site for professional, enthusiast and amateur photographers.

  • Sorry about the above comment by @mattdm. That was originally posted on Photo.SE. I migrated this question here, as it seemed most appropriate on GD.SE...and I thought you guys could use a beta boost. ;) – jrista Jan 29 '11 at 6:06
3

I know this seems silly, but have you tried rebooting your program and or computer? Also, have you tried typing in your own hexadecimal value on the color picker? (#ffffff is white).

  • +1 for the reboot suggestion. Adobe applications are resource hogs and chew up a lot of memory, Photoshop using the most by far. – Philip Regan Jan 28 '11 at 17:41
  • You can even set the amount of memory that you can use for each adobe software. – Littlemad Jan 29 '11 at 10:19
1

There are 3 ways to change colour

  • Select your text (editing selection) and change it from the left general toolbar of colour
  • Select the layer where is the font, open the Character/Type window and change from there
  • Select the layer, and than slect the "T" on the left toolbar should appear on the top of the screen a quick toolbar related to the proprieties of the tool selected, you can edit color from there
0

Is your image mode set to RGB/CMYK? If your image mode is grayscale, then you won't be able to use any colors in your image.

Edit:
Sorry, I should have read the question more carefully. Another possibility is that the type layer has a color overlay filter on it. See if there are any layer effects enabled.

  • 1
    They mentioned they are trying to change the color to black, so I doubt that's the issue. – Hanna Jan 30 '11 at 1:43
0

(ctrl+A - ctrl+C) copy everything into a new document. i had the same problem, it seems like some photos are locked or something so you cant edit certain features in them and copy/pasting was the easiest fix i found for this issue.

0

Try changing the Style option in the LayerStyle window, the problem may be caused by having selected a custom Style by mistake. Worked for me :)

0

Sometimes what happens is when you create a new document the color mode defaults to a lower setting like CMYK color at 8 bit. You can either create a new document and set the color mode to RGB at 16 bit or you can follow this link to change the color mode on existing documents. https://helpx.adobe.com/photoshop/using/converting-color-modes.html

Not the answer you're looking for? Browse other questions tagged or ask your own question.