0

I am working on a pattern of a bunch of tiled square shapes. I matched all of the shapes right next to each other until I get that little green "Align" line and let go. When I zoom out I see a little space between most of the shapes. I'm assuming that is so I can see what shapes I'm working with better because when I zoom in the lines go away.

However when I export as a jpeg or png the lines are actually there. I tried it twice to make sure I had all the squares lined up and I'm still getting white space between them. Any idea whats going on?

enter image description hereenter image description here

1

Make sure you have 'Align to Pixel Grid' deselected in the Transform panel.

enter image description here

  • Select all of the squares
  • Open the Transform panel
  • Make sure that the checkbox next to 'Align to Pixel Grid' is not ticked

If you can't see this option in the Transform panel, click 'Show Options' on the drop-down in the top-right of the panel.

  • I checked and 'Align to Pixel Grid' is not ticked. I even tried selecting it all, ticking it and unticking and I still get the same results – rotolee Apr 27 '16 at 16:40
1

I would actually set the "Align to Pixels" ON, since this will guarantee your shapes are actually aligned to the pixel grid.

From what I see in your screenshot, your anchor points are on fractional pixel coordinates, which will cause these spaces. To confirm, use Pixel Preview (Cmd+Y or Ctrl+Y on Windows). If you see the gaps there, you need to realign your shapes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.