I am having an issue with one artboard in my document, as you can see it is much larger than the rest, how do I fix this?

INDESIGN layout issue

7 Answers 7


If it's your pasteboard having that issue:

Try going to Preferences > Guides & Pasteboard > Pasteboard Options and you can adjust it from there. If that still doesn't fix your issue then, as the other answer suggests, you more than likely have something hidden on your pasteboard that's causing the size difference. Try removing the item individually and your pasteboard should reduce.

If it's your individual page having that issue:

As of InDesign CS5 there is a Page tool that will let you resize your pages individually. The icon for it can be seen below. page tool icon

Select the Page tool and then click the page you would like to edit, then where the Page tool was you should now see this: page icon handles

Make sure the top-left handle is selected (since your content from your image is all near the top-left and you're needing to bring the size in from the bottom-right) as seen in that image and from there you can adjust the width/height to fit your needs and make it the same size as the rest of your pages.

  • I suspect the problem is not the page size, but the artboard size which gets inflated by a possible hidden object.
    – Lucian
    Commented Apr 27, 2016 at 21:13
  • I see, thanks. I've adjusted my answer more accordingly. Commented Apr 27, 2016 at 21:18
  • If you want to know what's on the paste board, you can go to that page and right-click. Then, select 'Entire Pasteboard'. It will expand/contract the window contents to show the entire pasteboard. Next, change the view mode with the 'W'. That will toggle between design and preview modes. Preview mode will show only what is in your page and hides all other object outside of that area along with guides etc., and anything on your pasteboard. When you press 'W' again it will show everything in your pasteboard along with guides, anchors, etc.
    – nocturns2
    Commented Feb 27, 2020 at 19:52

This also happened to me recently with a file I took over from other designers.

It might be you are importing an IDML saved from a newer version? In any case this probably happens because of a hidden small object thrown outside the artboard.

What i did to resolve this was copy everything on the page (dont use select all but actually select via mouse all the items on your page without selecting anything outside the page), delete the page completely, add a new page and paste your clipboard.

This way you are sure to move your visible artwork to a fresh new page without leftover hanging artwork.


A similar solution to @Lucian's is to select (with mouse) all the content you want to keep, then use the "Lock" command (Cmd+L on a Mac, Ctrl-L on a PC) to lock all those items. Then Select All (Cmd+A), and hit delete.


I know this is super old now, but none of these answers worked for me when this happened to me. The absolute easiest solution was to insert a page either before or after the corrupted one. Move content from corrupted page to new page. Then delete the empty corrupted page(s).


For me: I copied all layers into a new spread, and deleted the old one with the increased pasteboard.

Turns out, one of the layers was a path way up the pasteboard which caused the issue.

  • This seems to me to be exactly what the other answers say.
    – Wolff
    Commented Mar 10, 2020 at 22:15

To find something hidden on the pasteboard (something you might not have even put there?) select all. Now you can see the culprit and remove it.


I figured it out. If you go to the page with the giant artboard and turn off all the layers, and then turn on each layer one by one, and as you do, simply do a Select-All to see what's on that layer. Sooner or later you'll find the object that goes way off into oblivion which is making the artboard so large. Just delete that object and bingo, the artboard reverts back to a normal size. I just fixed two jumbo artboards that way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.