1

I'm trying to move elements around on the grid, but Photoshop CC keeps trying to snap to other elements in the image. I've tried turning off View > Snap and then turning on View > Snap To > Grid so the Grid is the only thing it should snap to, but it still insists on snapping to other elements.

To clarify, in the picture below (I'm making a texture where the text should be center-aligned on multiples of 32) the green dotted lines are my grid and magenta lines/numbers are PS trying to snap to other objects when I move "SEP". Due to inconsistencies in letter height of this font, trying to align to the edges of other text elements in that row are not always precise, and now instead of snapping to a single point (the center gridline), it's trying to snap to bottom alignment, top alignment, and all sorts of other messy places.

enter image description here

  • Have you tried Snap To > None and then Snap To > Grid? Sometimes the editor prefs often get corrupted. You may need to rebuild the editor preferences to resolve any conflicts. Hold down the Ctrl+Shift+Alt keys and simultaneously click on Edit on the welcome screen. Release the three keys and look behind the welcome screen. You should see a pop up box with the words: Delete Adobe Photoshop Elements Settings File? Click on Yes Close down Elements and re-open it in the normal way - then wait whilst it rebuilds the preferences. – Brenn Apr 28 '16 at 16:17
  • Yes, I toggled the snapping as I'd described in the second sentence. Tried deleting preferences (though this is Photoshop CC on Mac, not Photoshop Elements; had to hold cmd+shift+alt while starting up) to no avail. – Doktor J Apr 28 '16 at 21:52
2

Background

Found out what I needed to do! The culprit is Adobe's so-called "Smart Guides"; they do not have an option in the View > Snap menu, which is why I went around and around for hours without figuring out a way to disable them.

I hit up Google again today, and eventually discovered that the offending feature was called "Smart Guides", so I turned around and plugged that into my query and after trawling through a bunch of posts that ended up being complaints about Frame Edge highlighting in InDesign and other Adobe apps, I finally came across this SU answer.

The Solution

Navigated through the menu to View > Show > Smart Guides ... uncheck that, and PRESTO, no "smart" guides, no more elements trying to snap to other elements I don't want them snapping to!

Misc. Gripe

I can see the usefulness of Smart Guides, but really, Adobe should separate Smart Guides from regular Guides in the Snap To menu; I may be using manually-set guides and still want to snap to those but not snap to the "smart" guides. Turning off Snap To Guides does stop snapping to Smart Guides, but then I also lose snapping to manual guides.

1

with Photoshop 20, I had this crazy autosnap that occurred anyway when I tried to use the distort function.I found out that holding the SHIFT key while moving the anchors points temporarily disable this annoying autosnap. Hope it will help some other photoshop users who got crazy with this issue.

  • Thanks for the input! I think that disables all snapping though, including snapping to manually-set guides; in the original problem I'd encountered, I was trying to snap to my manual guides, it was just prioritizing its stupid automatic "smart" guides over my manual guides! – Doktor J Nov 14 '18 at 16:35
0

I fought this for 90 minutes on my Mac! Finally, saved the file and quit my old CS4 Photoshop and RESTARTED Photoshop, not a reboot and had no issues!

Sometimes I need the command key to maintain a selection of the correct layer before sliding it with the Move Tool.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.