1

I have a MacBook Pro with a second display attached. When I work, I usually have the following setup:

  • MacBook display: Messages and Chrome in split-screen mode (full-screen)
  • Second display: Indesign/Illustrator/Photoshop (full-screen)

In the Dock on the second display I've right-clicked on my Adobe apps and clicked Options > Assign to Desktop on Display 2, which means that the apps open up on the second screen.

My problem is, however, that when I'm using one of these apps on my second display and I do something that brings up a dialog box (Save, Export etc) or a panel that isn't already open on the second display, it opens it in the background on my MacBook screen. It seems that, because I'm using split-screen (full-screen) mode on my MacBook, it brings the dialog box or panel up on a non-full-screen Space in the background.

Is there a way to have these dialog boxes and panels pop up on the application display/Space by default?

  • 1
    The only solution I know, is to make the second screen your main display in System preferences > Displays > Arrangement...: move the white bar at the top of one of the screens to the other screen. – Joonas Apr 29 '16 at 7:00
  • Thanks @Joonas, I might try this. I wonder what happens when I disconnect the second display and reconnect it though - will it 'remember' that the second display is the primary one? – Alex Apr 29 '16 at 12:10
  • It will remember that. – Joonas Apr 29 '16 at 12:32
  • @Joonas you should make that an answer :) – Cai Apr 29 '16 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.