3

On occasion, I have to edit multilingual documents in InDesign, containing both English and Arabic. My system locale is English. I've got Indesign set up to display the Arabic text correctly, but this has one infuriating side effect: when I place the cursor in an Arabic paragraph and I use the left/right arrow keys to move the cursor, their behavior is mirrored. When I press left-arrow the cursor moves to the right. Right-arrow moves the cursor to the left.

This gets worse when you have English words in an Arabic paragraph: inside the English word the cursor behaves normally, at the boundary English-Arabic cursor behavior swaps. This makes it nearly impossible to select a word. Mouse behavior is similarly erratic: when I drag over a word to select it, it will leave out the first or the last character.

Is there a way to end this insanity and make the cursor behave normally?

1

I've had the same issue in documents translated into Urdu - mostly Arabic alphabet but still some English text (contacts, etc.).

The solution to your question may be to change the Cursor Control setting in 'Preferences > Right to Left'. See explanation on this Arabic/Hebrew Help page under 'Right to Left writing preferences'.

My personal workaround is to not drag the cursor over words to select them. Instead I double-click a word to highlight it. Then I hold the shift key, place the cursor at the far edge of the text I want to select and click. Shift-clicking selects all the text between the earlier highlighted part and where the cursor is. I personally find this helps a lot and I've got used to the reversing issue. Different strokes for different folks...?

  • That seems to be a setting unique to the ME edition which I don't have. – Hobbes May 10 '16 at 10:14
  • If you have InDesign CC you can download the Middle East edition (does require reinstalling ID). Change your CC language preference to English/Arabic, then you should be able to download the ME edition. Once you've installed it, change your language pref back. If you have a CS version then you'd need to try the workaround instead. – Dub Scrib May 10 '16 at 10:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.