4

On a U.S. keyboard, you use the Option/Alt+[ or ] keys to move up and down layers.

My problems is that the brackets on the Scandinavian keyboard are located on the 8 and 9 number keys and do not work with the same short cuts.

| improve this question | | | | |
  • Check your keyboard shortcuts under Edit -> Keyboard Shortcuts – Hanna May 12 '16 at 13:53
  • @Johannes you can't edit those shortcuts, they aren't in the 'Keyboard Shortcuts' list for some bizarre reason. – Cai May 12 '16 at 15:34
  • What OS are you using? – Cai May 12 '16 at 15:40
  • I've been digging through my shortcuts list, to find them, with no luck too. I actually just posted on the Adobe forum about this, because I'm curious as well. I'll post any relevant information I get over there here, to help. – Manly May 12 '16 at 15:50
  • I'm using Windows 7. It's the same for resizing the brush using the square brackets only, doesn't work. There's another decent shortcut for that, alt + right click & drag on windows but it would be useful to traverse the layers with a shortcut. – Larry Lawless May 12 '16 at 19:11
3

A friend helped me find the solution!!

Here's my trick: First change to US keyboard. (win+space if you're on W8 or W10)

In Photoshop, use the Actions Panel! To keep it tidy, create a new group so you don't mix it with default actions. Create a new action and map it to f.ex. 'F2' in the create new actions dialogue. Record, and Enter 'Alt+LeftBracket' with US Keyboard active. Photoshop will save the command 'Select previous layer'. Create a new recording, map f.ex. 'F3', type 'Alt+RightBracket' and PS will record 'Select forward layer'. Now feel free to change your Keyboard back to your conspicious, outlandish, non-american layout.

F2 and F3 will give you layer select up and down!

Happy days!!

| improve this answer | | | | |
  • Great solution! – Cai May 12 '16 at 21:41
1

Some keyboard shortcuts in Photoshop are hard-coded and can't be changed through the normal Edit → Keyboard Shortcuts... way (including the Alt + [/] shortcuts).

Depending on your OS, there are a few workarounds. Basically you either change your keyboard layout, or remap the shortcuts. Any OS should have methods for relatively easily changing keyboard layouts. In OS X you can open keyboard preferences, add a new keyboard input and check 'Show Input menu in menu bar' so you can easily switch between layouts.

| improve this answer | | | | |
-1

I've found a solution, in case someone is still looking for a method.

You can use:

cmd+option and 8/9

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.