4

i have these little white gaps between the rectangles (only in exported .svg files) In illustrator im able to zoom in as far as possible without seeing any of these

Is there a way to fix this? I already rebuild the thing with "Align to pixel grid" off.. But it changed nothing.. I tryied also combining the rectangles with the path finder, but thats only possible with rectangles of the same color (afaik, correct me if im wrong)..

enter image description here

the .ai file: host.lohr-it.de/tree.ai .svg file

3

Those lines are a result of the anti aliasing settings inside Illustrator. If you have a computer that supports GPU processing, as opposed to CPU, you can enable the GPU settings by going to View > GPU Preview (+E) and that will get rid of them.

You can also refer to this post, which is basically asking the same thing you are and describes two workarounds.

If you were saving this as a PNG, for instance, you could select "Art Optimized" in your aliasing settings.

anti aliasing

The SVG settings in Illustrator don't seem to allow that (from what I can tell), so other than adding a stroke around the shapes or a shape below them to fill the implied lines, I'm not sure what else to do.

I opened your SVG file in AI and the lines are not visible to me, with GPU mode enabled. Even with CPU mode enabled, the lines are only visible at certain levels of zoom.

tree

  • The lines are not visible in Illustrator for me too. But if i export it as .svg and then open that file with Google Chrome or Firefox, these gaps are there. – michidk Jun 1 '16 at 0:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.