1

I have a table in InDesign that looks like this:

enter image description here

When I use the AutoTag feature and export the resulting XML, I get XML that looks like this:

  <Table>
     <Table xmlns:aid="http://ns.adobe.com/AdobeInDesign/4.0/" aid:table="table" aid:trows="2" aid:tcols="9">
        <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">12:00-2:59Am</Cell>
        <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">3:00-5:59Am</Cell>
        <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">6:00-8:59Am</Cell>
        <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">9:00-11:59Am</Cell>
        <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">12:00-2:59pm</Cell>
        <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">3:00-5:59pm</Cell>
        <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">6:00-8:59pm</Cell>
        <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">9:00-11:59pm</Cell>
        <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">TOTALS</Cell>
        <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">3,329</Cell>
        <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">4,861</Cell>
        <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">9,766</Cell>
        <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">2,428</Cell>
        <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">1,889</Cell>
        <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">3,605</Cell>
        <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">10,857</Cell>
        <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">8,923</Cell>
        <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">46,658</Cell>
     </Table>
  </Table>

I want the XML to look like this:

     <Table>
         <Table xmlns:aid="http://ns.adobe.com/AdobeInDesign/4.0/" aid:table="table" aid:trows="2" aid:tcols="9">
            <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">12:00-2:59Am</Cell>
            <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">3,329</Cell>
            <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">3:00-5:59Am</Cell>
            <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">4,861</Cell>
            <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">6:00-8:59Am</Cell>
            <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">9,766</Cell>
            <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">9:00-11:59Am</Cell>
            <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">2,428</Cell>
            <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">12:00-2:59pm</Cell>
            <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">1,889</Cell>
            <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">3:00-5:59pm</Cell>
            <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">3,605</Cell>
            <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">6:00-8:59pm</Cell>
            <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">10,857</Cell>
            <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">9:00-11:59pm</Cell>
            <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">8,923</Cell>
            <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">TOTALS</Cell>
            <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:ccolwidth="29.99">46,658</Cell>
         </Table>
      </Table>

But I can't seem to tag individual rows or columns in the table. When I highlight specific cells, the tag button greys out, and when I right-click, the table options menu shows up (insert, delete, select, merge cells, etc.).

Is there a way I can force the XML text to be column-by-column instead of row-by-row?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.