1

enter image description hereCan someone help with this problem in Inkscape? When I attempt to draw an empty rectangle with stroke, what I get is a rectangle with stroke which lines are a little bit thicker on the left and right side compared to the top and bottom lines. In the process of drawing it the lines are still equal but once the rectangle is made they automatically change. I think it's something in the settings, but I just can't figure what it is. If I open a new Inkscape document, I don't have this problem anymore, but I just want to know what's the trick here. Does anyone know? cheers

  • 3
    Wow, interesting. It looks like you've scaled it after creating it, but I assume that's not the case? – falstro Jun 4 '16 at 15:21
  • 2
    Can you please post an SVG file with the rectangle? – Paolo Gibellini Jun 6 '16 at 8:06
1

If you only suspect the settings, then try
Edit > Preferences > Behavior > Transforms > uncheck scale stroke width.

If this does not fix the problem, you may have a problem with the document. I could recreate the problem/effect by applying a transformation to the current layer (using the xml editor). If such an transformation is the problem for you, there are two possible ways around it.

  1. Create a new layer (layer > add new layer. Or ctrl+shift+n) and draw only on the new layer.

or

  1. Open the xml editor (<>-icon in the toolbar. Or ctrl+shift+x). On the left, search for nodes like <svg:svg … or <svg:g …. Select such nodes and look for transform-attributes on the right-hand side. If there is a transform, select it and press DEL to delete it. Warning: This affects everything in the group.
    deleting transformations
  • There's also a button in the toolbar to control scaling the stroke width. (As of v0.91, it's the first button after the width/height boxes.) – SilverWolf Jun 15 '18 at 14:26
0

I've had that happen before, but usually only when I'd already created an object with a particular stroke, then converted it to a path, and then resized it using the object-resize handles.

The fix for me was to just re-define the stroke width in the "Fill and Stroke" dialog.

0

I came across this problem too when I used the rectangle tool. You need to change the "Store transformation" option in your preferences to Preserved:

Edit → Preferences → Behavior → Transforms → Store transformation

This solved it for me. I also prefer to not scale anything at all with transforms. So if you'd like that, you can disable that too in that preferences section.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.