How can I auto cut the overlapping stuff outside the artboard when I save for web and/or just while using "normal export"?

When I'm in the save for web window the image is bigger then the artboard size because of layers who are out of the artboard size. I'd like to auto cut all overlapping stuff when saving/exporting just like it was in CC 2015.0.0.

Like working without the artboard future.

I'm running version CC 2015.1.2

  • 1
    You may need to be specific about this "new version" (I don't have a new version) and as far as I'm aware what you want to do is how it should work. "new version" will also be pretty meaningless to future readers. – Cai Jun 7 '16 at 16:07

Try File>Export>Export As...

That will save each artboard as their own file.


Ensure that you have selected the "Clip to Artboard" option, in your Save for Web options. Otherwise, Illustrator will automatically crop the output to your artwork's full dimensions.

enter image description here

  • The user might be talking about Adobe Photoshop CC since that tag is used. – AndrewH Jun 7 '16 at 20:36
  • @AndrewH didn't even catch that! I still forget that PS even has artboards now. I see "artboard" and instantly think AI. I tried to replicate their error in PS and can't. Mine is respecting my artboard and cropping the larger stuff. – Manly Jun 7 '16 at 20:39

enter image description here

Make sure to Select the Art-board and the Hit " Ctrl + Alt + Shift + S " for save for Web Or you could also do the normal export " File > Export > Export As " Here you can select the Artboard you want from the left side. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.