0

I'm data merging a csv file into a indesign file to export buisness cards. However when I select the csv for data merging, Indesign reads the file and should display the columns in the file as seperat entries, but instead it combines them into one:

screenshot of indesign data merge read error

The data should show up as individual entries for

  • Name
  • Rolle
  • Telefon
  • Email

Alas, not combined like in the screenshot.


The csv file is set up like this:

screenshot of csv file layout in excel

for obvious reasons I can't show the data, but there is 25 rows of data below, set up the same way as the sample data here.

Some data-fields contain the danish special-characters æ, ø and å (if that could play a role?).

  • Thank you! Could you post your comment as an answer? Then I'll mark it as correct. – ssssaaaa Jun 13 '16 at 21:24
2

CSV is comma-separated values. On some windows machines (when win is not English) the comma is changed with semi-colon. And in the result csv files are exported with ";" in place of ",". You can change it in windows regional settings or just save file as Tabbed Text.

2

No it's because InDesign looks for commas as a separator while Excel will use a semi-colon. Prefer Tabbed Text as export format. InDesign will like this better ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.