3

When I click on something, it selects, I believe, the largest object in a given radius from the click offset, not the path I've actually clicked on. Is there a way to increase the precision? Zooming in and out every time is starting to become a tedious operation...

  • Is the path selection tool (2nd from top) or the object selection tool (1st from top, arrow) activated? Imho the object from the top, which was added last or raised to the top, gets selected. – user unknown Jul 1 '16 at 15:41
  • I assuem you're using ctrl+mouse wheel for zoom, combined with clicking/dragging the mouse wheel for panning. That should minimise the tedium – Chris H Aug 31 '16 at 12:48
2

Normally Inkscape selects the topmost that occupies the exact position where you click.

There are many ways of selecting objects with the mouse. You may be interested in /select under/ for selecting objects not at the top.

  • This does not answer the question. The answer of Evgeni Sergeev is the correct one. It also explains the reason of this sometimes upsetting behaviour. – brett Dec 17 '18 at 13:16
1

you can select above element and press '3' to zoom. I think is better than zooming in and out.

  • While this is a great tip, it often doesn't help. Consider e.g. a fine dotted rectangle used as a border for something large. Pressing <3> zooms to show the whole object so the dots that might be your target get smaller. This sort of thing is fairly common for me, with the tiny target being the tick mark on a graph and the nearest easy target being an axis. – Chris H Aug 31 '16 at 12:46
1

From Dmitry Kirsanov's book:

Also, you will notice that every clickable object has an invisible margin, several pixels wide, on all sides. A click in that margin will still select that object. [...] On the downside, this also explains why it's sometimes so difficult to select the bottom object in a stack even if that bottom object protrudes a little from under the top one.

If you don't like the size of this clickable margin, you can change it on the Mouse tab of the Inkscape Preferences dialog: Adjust the Grab sensitivity value, the default being 8 screen pixels.

For some reason, I had to restart Inkscape for this to take effect.

  • This here is the only correct answer. This has been driving me nuts, now it works allright. I guess the setting is there to help you click on lines (i.e. objects made of lines, without fill). Setting it to 2 instead of the default 8, is a good balanced value for this setting. – brett Dec 17 '18 at 13:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.