0

Using InDesign, I am trying to make my multi-column justified text homogeneously spaced, i.e. the inter-word spacing equally distributed across the entire page (or article).

As you can see below, the text is a total mess : there are different inter-word spaces, even in the same line (for example, compare the space between the 1st and 2nd words of the 2nd line, and the one between the 2nd and 3rd words of said line) !

How can I fix this ?

screenshot

2

You can, by changing InDesign's default Justifications parameters. However, you should not do nor want to do that.

Starting with replicating your result:

original bitmap and replicated text

– this is 11/13 pt Times New Roman in a frame 60.5mm wide –, I found I had to insert multiple spaces in exactly those places in your "total mess". In modern typesetting, entering multiple spaces in running text is not only not necessary (in HTML, for instance, the default is any amount of spaces is equal to exactly 1), but as you can see it messes with the built-in justification algorithm.

By changing the allowed word justification limits to Minimum 100%, Desired 100%, and Maximum 100%, you can force InDesign to not change the space widths. Since apparently (and weirdly) you still want your text fully justified, you need to allow either intraword spacing differences (the letter spacing) or glyph scaling (or, as it is, a combination of the two). Just for laughs, I set the Letter Spacing to -10%, 0%, 10% and got this result:

letter spacing only

This is what you asked for: all of the spaces have the same width, and the text is justified. Some of the interword spaces are larger than others, but that is because there are more spaces in those positions.

I could stop with this because it is what you asked, but I started out with telling you really should not do this. The proper way is:

  1. Do not have multiple spaces inside your running text. None. Not even after the full stop.
  2. Set letter spacing variance to an absolute minimum. InDesign's own defaults are 0%,0%,0%, that is, no variance at all.
  3. Set word spacing variance to reasonable values. InDesign's defaults are 80%,100%,133% and are perfectly alright for a wide range of fonts, sizes, and column widths. For small columns such as yours you may need to decrease the Minimum to about 75% and perhaps the Maximum to 150%, to prevent lots of words being hyphenated (then again, don't do this if you want your spacing to be more consistent).
  4. Rely on InDesign's highly advanced, patented Full Justification algorithm. Other than most typesetting software, InDesign distributes its spacing all over an entire paragraph. That means that every single line is justified the best way it can, considering all other lines as well (i.e., slightly changing the spacing on one line for the better will make at least one other line much worse).

With the Justification settings left at their defaults and with all of your double spaces removed, your snippet of text looks "just right" to me:

hey look! perfectly justified text!

  • 1
    Setting word-spacing to 100% won't force ID to respect space widths in justified text though, unless you set enough letter-spacing or glyph-scaling – Cai Jul 4 '16 at 13:23
  • 1
    Can I get you to capitalize the first letters in your list? – Stan Jul 4 '16 at 13:27
  • @Cai: I am not too sure about that part of ID's spacing. I do know for a fact that it happily goes beyond what's asked with respect to word spacing (there is a highlight option for that in the Preferences), but in this case it seems the reverse: should word spacing be adjusted when the letter spacing cannot go beyond its stated boundaries? (I am not curious enough to try. I already gave 4 pretty good reasons for that.) – usr2564301 Jul 4 '16 at 13:35
3

Edit: It's not impossible per-se. But impossible without changing some other spacing (which you probably don't want to do) (see Rad Lexus' answer)


You can't. It's impossible.

If all the spaces were equal you would no longer have equal line lengths (i.e. not justified). There is no way around that.

The justification options in your paragraph style (Word Spacing to be specific) will help you a bit, but there is no way to make the spaces completely (or anything that close to) equal.

  • Across lines or paragraphs, sure. But within a single line, InDesign ought to adjust word spacing to avoid such dreadful eyesores as the second line in the example given. I have no idea how that one even happened, never saw InDesign mess up spacing like that before. – Janus Bahs Jacquet Jul 2 '16 at 22:39
  • 1
    Usually when the spaces within the same line are uneven, there are either double spaces involved or spaces with a fixed with. You should make sure that between each word is a single, regular space only. – mdomino Jul 3 '16 at 22:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.